Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

MSExchangePOP3 service crashes in an Exchange Server 2007 environment


View products that this article applies to.

Symptoms

When a client issues a QUIT�command to end a POP3 session, the MSExchangePOP3 service crashes occasionally on a Microsoft Exchange Server 2007 Client Access server. Additionally, the following event is logged in the Application log:
Log Name: Application
Source: Application Error
Date: Date
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Computer
Description:
Faulting application name: Microsoft.Exchange.Pop3.exe, version: version, time stamp: time stamp
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: offset
Faulting process id: process id
Faulting application start time: start time
Faulting application path: C:\Program Files\Microsoft\Exchange Server\ClientAccess\PopImap\Microsoft.Exchange.Pop3.exe
Faulting module path: unknown
Report Id: report id

↑ Back to the top


Cause

This issue occurs because of a NullReferenceException exception when the Exchange server processes a POP3 session quit command. The NullReferenceException exception is caused by a race condition during the POP3 session object disposal. In this race condition, the VirtualServer object is set to NULL before it is used. Therefore, the MSExchangePOP3 service crashes.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2655203 Description of Update Rollup 7 for Exchange Server 2007 Service Pack 3

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the QUIT command, visit the following Microsoft website:

↑ Back to the top


Keywords: KB2677979, kbexpertiseinter, kbsurveynew, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 2677979
Revision : 1
Created on : 4/16/2012
Published on : 4/16/2012
Exists online : False
Views : 311