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"0xC0000244" Stop error occurs when the Security log reaches its maximum size in Windows Vista or in Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You enable the following Group Policy settings on a computer that is running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2:
    Computer Configuration\Administrative Templates\Windows Components\Event Log Service\Security\Backup log automatically when full
    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Audit: Shut down system immediately if unable to log
  • You enable the Archive the log when full, do not overwrite events option in the Security log.
  • The Security log reaches its maximum log size.
In this scenario, the computer crashes. Additionally, you receive the following Stop error message:
0xc0000244 - {Audit Failed}
An attempt to generate a security audit failed.
Note The expected behavior is that the computer backs up the Security log when the log reaches its maximum size, and the computer does not crash.

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Cause

This issue occurs because the Windows Event Log service incorrectly generates the "0xc0000244" Stop error code before the service backs up the Security log.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTime
Wevtsvc.dll6.0.6002.227911,020,41603-Feb-201214:48
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTime
Wevtsvc.dll6.0.6002.227911,495,55203-Feb-201221:21
For all supported IA-64–based versions of Windows Server 2008
File nameFile versionFile sizeDateTime
Wevtsvc.dll6.0.6002.227912,707,45603-Feb-201214:16

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2546548 "0xC0000244" Stop error when the Security log reaches its maximum size in Windows 7 or in Windows Server 2008 R2

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_2d6c8e428c97551e054679acd3d66652_31bf3856ad364e35_6.0.6002.22791_none_ef08fb3ea44081e8.manifest
File versionNot applicable
File size696
Date (UTC)03-Feb-2012
Time (UTC)22:50
File nameX86_microsoft-windows-eventlog_31bf3856ad364e35_6.0.6002.22791_none_ded42ce129651fa1.manifest
File versionNot applicable
File size47,715
Date (UTC)03-Feb-2012
Time (UTC)15:03
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_3ed82008db040500b4537056b521114d_31bf3856ad364e35_6.0.6002.22791_none_e8dddbc98e285241.manifest
File versionNot applicable
File size700
Date (UTC)03-Feb-2012
Time (UTC)22:50
File nameAmd64_microsoft-windows-eventlog_31bf3856ad364e35_6.0.6002.22791_none_3af2c864e1c290d7.manifest
File versionNot applicable
File size47,983
Date (UTC)03-Feb-2012
Time (UTC)21:41
Additional files for all supported IA-64–based versions of Windows Server 2008
File nameIa64_b81aafb11d2799ddc89d843dda426ebe_31bf3856ad364e35_6.0.6002.22791_none_f9f695d5c5f56b16.manifest
File versionNot applicable
File size698
Date (UTC)03-Feb-2012
Time (UTC)22:50
File nameIa64_microsoft-windows-eventlog_31bf3856ad364e35_6.0.6002.22791_none_ded5d0d72963289d.manifest
File versionNot applicable
File size47,973
Date (UTC)03-Feb-2012
Time (UTC)14:26

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2673371
Revision : 1
Created on : 1/7/2017
Published on : 1/4/2013
Exists online : False
Views : 248