Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Windows logoff process is delayed when Lync 2010 is started


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You log on to a user account that is not enabled for Microsoft Lync Server 2010 on a computer.
  • You have never tried to use any sign-in address to sign in to Lync 2010 on the computer. 
  • You log off the account.
In this scenario, the logoff process is delayed for several seconds. Additionally, Windows displays a message that states Lync 2010 is preventing computer from logging off.

Note This issue also occurs when you try to restart or shut down the computer.

↑ Back to the top


Cause

This issue occurs because Lync 2010 calls a function that takes 20 seconds to perform a cleanup task when Windows logs off, shuts down or restarts. The function is called when the AccountProfiles.dat file does not exist in the user profile.

Note The AccountProfiles.dat file is not present when Lync 2010 has never been signed in with any sign-in address.

↑ Back to the top


Resolution

To resolve this issue, install the following cumulative update:
2670326 Description of the cumulative update for Lync 2010: February 2012


↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2666324
Revision : 1
Created on : 1/7/2017
Published on : 3/1/2012
Exists online : False
Views : 311