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Outlook Junk Email settings ignored after you move a mailbox to Exchange Server 2010


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Symptoms

When you migrate or move your mailbox to Office 365 or to an on-premises Exchange Server 2010 server, you experience one or more of the following symptoms:
  • Junk E-Mail settings deployed by using Group Policy either fail to run or fail to take effect. These settings include Safe and Blocked Sender Lists and the Outlook Junk E-Mail filtering enabled/disabled setting.
  • When you use Outlook to add an email address to the Blocked or Safe Senders Lists, the address is either not displayed in the list or it is displayed in the list, but never synchronized to the Exchange mailbox.
  • Messages are unexpectedly marked as junk email.
  • Messages fail to be marked as junk email.
  • You notice differences between the Safe Senders List displayed in Outlook and Safe Senders as displayed in Outlook Web App (OWA).
Note This specific issue is present only after a mailbox is moved to an Exchange Server 2010 database. This should not be confused with other junk email issues.

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Cause

The Junk Email rule is damaged or was generated incorrectly when migrated to an Exchange Server 2010 mailbox.

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Resolution

To resolve this issue, install the following update rollup before you move or migrate a mailbox:
2685289 Description of Update Rollup 3 for Exchange Server 2010 Service Pack 2
Note This update rollup will not resolve this issue if you apply the update after you move or migrate a mailbox.

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Workaround

To work around this issue, there are multiple options.
  • Use the MFCMAPI Editor tool to delete the Junk E-mail rule. Note this method may result in the loss of your original junk email settings.
  • Use OWA to add an entry to the Safe or Blocked Senders Lists. Then, start Outlook and either manually add an item to the Safe or Blocked Senders Lists or use Group Policy (GPO) to update the list. In some cases, you may have to start Outlook multiple times.
  • Add items to the Safe Senders List by using Exchange PowerShell. Exchange PowerShell commands can be used to append items to the Safe or Blocked Senders lists of multiple mailboxes in bulk.

    For more information about how to use Exchange PowerShell commands to add entries to the Safe or Blocked Senders lists, click the following article number to view the article in the Microsoft Knowledge Base:
    2545137 How to configure the safe senders and blocked senders settings in Office 365
    Note This article applies to both on-premise and Office 365 mailboxes. BPOS users should open a case with BPOS OPS.
  • Use a script to correct the junk email rules. A code sample of the script is available on the following Microsoft TechNet website:

    http://gallery.technet.microsoft.com/scriptcenter/Fix-junk-email-rule-script-7202a7f8
For more information about a similar issue that occurs after you move or migrate a mailbox, click the following article number to view the article in the Microsoft Knowledge Base:
2695011 Junk Email settings do not work as expected after you migrate or move a mailbox to an Exchange Server 2010 SP1 Mailbox server

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More Information

When the condition described in the "Symptoms" section occurs, when you use MFCMAPI to view the Junk E-mail rule, the Subject is missing. The following screen shot shows the Junk E-mail rule with the missing subject (PR_SUBJECT):The screen shot that shows the Junk E-mail rule with the missing subject (PR_SUBJECT).




The PR_EXTENDED_RULE_CONDITION MAPI property contains both the Blocked and Safe Senders Lists.

The screen shot of the PR_EXTENDED_RULE_CONDITION MAPI property in Property Editor.

You can compare what you see in the Outlook junk e-mail user interface (UI) against the Text string value of the earlierMAPI prop. This may help you determine whether the values that are shown in Outlook and those that were synchronized with the server are mismatched.

Additionally, some Safe and Blocked Senders information may be stored in the following registry key:
 
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\<PROFILE>\<GUID>

The following registry values correspond to the following junk e-mail lists:
 
Value List
001f0418 Safe Senders
001f0419 Trusted Recipients
001f041a Blocked Senders
001f041c Contacts

How to delete the Junk E-mail rule by using MFCMAPI

  1. Export the safe senders and blocked senders list to a text file by using the steps in the following article:

    Export addresses from the Junk Email Filter lists
  2. Exit Outlook and close OWA on all workstations that are connected to the user mailbox.
  3. Download MFCMAPI from github (scroll down and then click Latest release).
  4. Run MFCMAPI.exe
  5. Click Tools, then click Options.
  6. Click to enable Use MDB_ONLINE when calling OpenMsgStore.
  7. In the Session menu, click Logon.
  8. If you are prompted for a profile, select your profile name, and then click OK.
  9. In the top pane, locate the line that corresponds to your mailbox, then expand Top of Information Store.
  10. Right-click Inbox and select Open associated contents table.
  11. In the top pane, locate and select the message that has a Message Class of IPM.ExtendedRule.Message.
  12. Right-click the IPM.ExtendedRule.Message and select Delete message.
  13. In the Delete Item window, select Permanent delete passing DELETE_HARD_DELETE (unrecoverable) and then click OK.
  14. Close out of MFCMAPI
  15. Start Outlook.
  16. Verify the Safe Senders, Safe Recipients, and Block Senders lists are empty.
  17. Finally, import the email addresses into Junk Email Filter Lists by using the steps in the following article:

    Import email addresses into Junk Email Filter Lists

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Article Info
Article ID : 2655142
Revision : 6
Created on : 11/15/2019
Published on : 11/15/2019
Exists online : False
Views : 310