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You receive a script error and are unable to print from Internet Explorer 9


View products that this article applies to.

Summary

You may receive a script error similar to the following when trying to print a webpage from Internet Explorer 9.

Note: Line number may be different.

An error has occurred in the script on this page.
Line : 2053
Char: 1
Error : Invalid procedure call or argument.
Code: 0
URL: res/ieframe.dll/preview.js.

If you have problems printing in Internet Explorer and are not getting a script error, see Unable to print or view the print preview of a webpage in Internet Explorer.

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Cause

You can get this error if your printer driver is outdated, incompatible, or corrupt. To fix this, follow the steps in the resolution section below.

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Resolution

To fix this, download and install the latest drivers for your printer. There are three ways to find and install the latest printer driver. Use the steps below starting with the first step. If that step doesn't work, go to the next step.

Disconnect, and then reconnect your printer to your PC

  1. Unplug the printer's USB cable from your PC.
    Note:For wireless printers, turn the printer off.
  2. Open Devices and Printers by clicking the Start button Picture of the Start button , and then, on the Start menu, clicking Devices and Printers.
  3. Right-click your printers icon and select Remove device.
  4. Reconnect your printer to your PC using the USB cable.
    Note: For wireless printers, refer to the information that came with the printer for installation instructions.
If disconnecting, and reconnecting your printer did not solve the issue, continue to next step.

Update your printer drivers using Windows Update

You might need to set Windows Update to automatically download and install recommended updates. Installing any important, recommended, and optional updates can update system features and other software that might help to fix your printer problems. To update to the latest printer driver for your printer using Windows Update, click the link specific to your version of Windows and follow the steps in the that article:

Find and install printer drivers in Windows 7

Find and install printer drivers in Windows Vista

If updating your printer driver using Windows Update did not solve the issue, continue to the next step.

Update your printer drivers from the device manufacturer

If your printer came with a disk, that disk might contain software that installs a driver for your printer. If your printer did not come with software, it may be necessary to go to the manufacturer's website to locate, download and install the latest printer driver for your printer.

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Workaround

If all methods in "Resolution" Section still cannot solve the issue, try the following workaround methods.

Method 1 Print using Internet Explorer 9 (32bit) instead of Internet Explorer 9(64bit)

  1. Click the Start button Picture of the Start button , type Internet Explorer in the Search programs and files, and then choose Internet Explorer.
  2. Try to print again.

Method 2 Print using Run as administator for Internet Explorer

  1. Click the Start button Picture of the Start button , type Internet Explorer in the Search programs and files.
  2. Right click Internet Explorer in Programs and click Run as administrator.
  3. Try to print again.

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More Information

For information on how to troubleshoot other script errors in Internet Explorer, see How to troubleshoot script errors in Internet Explorer on Windows-based computers

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Keywords: kbcip, kb

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Article Info
Article ID : 2652062
Revision : 4
Created on : 7/18/2018
Published on : 12/19/2018
Exists online : False
Views : 357