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Error: Service pack not supported when attempting to install Internet Explorer 9


View products that this article applies to.

Symptoms

When you install Internet Explorer 9, you receive the following error message:

Error: Service pack not supported.

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Cause

The installation of Internet Explorer 9 includes the installation of additional prerequisite software and components, based on the destination operating system. Internet Explorer 9 will try to automatically install prerequisite software and components. If the installation of prerequisite software and components does not succeed, Internet Explorer 9 �will not be installed. If this occurs, you must manually install the prerequisite software and components.

Note: Internet Explorer 9 might not automatically install prerequisite software and components if the installation of other updates is in progress or if a system restart is pending. To determine whether installation of updates is in progress or a restart is pending, take the following action for your operating system:

For Windows 7
Click�Start, click Control Panel, choose Large icons or Small icons from the View by drop-down list, and then click Windows Update.
For Windows Vista
Click�Security in Control Panel, and then click Windows Update.

If there is an update installation in progress, allow the installation to complete before you try to install Internet Explorer 9. If updates have been installed but the system has not yet restarted, restart your computer before you try to install Internet Explorer 9.

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Resolution

Method 1: Make sure that your system meets the minimum operating system requirements

To install Internet Explorer 9, one of the following operating systems (or later versions) is required.
  • Windows Vista (x86 and x64) with Service Pack 2 (SP 2)
  • Windows 7 (x86 and x64)
  • Windows Server 2008 (x86 and x64) with Service Pack 2 (SP 2)
  • Windows Server 2008 R2 x64

If you are running Windows Vista or Windows Server 2008 without Service Pack 2, install the latest service pack.

For more information about how to install the latest service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain the latest service pack for Windows Server 2008, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest Windows Server 2008 service pack

Method 2: Install required software and components

Internet Explorer 9 tries to install software prerequisites automatically. If installation of the prerequisites does not succeed, Internet Explorer 9 does not continue with the installation. In that case, please install the prerequisites manually. In that case, click the following article number to view the article in the Microsoft Knowledge Base and install the required software and components manually. And then go to Internet Explorer Home to install Internet Explorer 9 again.
2399238 Prerequisites for installing Internet Explorer 9

Method 3: Complete the installation of other updates

Before you try to install Internet Explorer 9, make sure that installation of other updates or a system restart is not pending. To check whether you have any pending installation of updates or a pending restart, complete the following step for your Windows operating system:

For Windows 7:
Open�System and Security in Control Panel, and then click Windows Update.
For Windows Vista:
Open�Security in Control Panel, and then click Windows Update.If there is an update installation in progress, let the installation finish before you try to install Internet Explorer 9. If updates are installed but a system restart has not yet occurred, restart your computer before you try to install Internet Explorer 9.

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More information

For more information about downloading Internet Explorer 9, visit the following Microsoft Website: Internet Explorer Home

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: KB2651597

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Article Info
Article ID : 2651597
Revision : 1
Created on : 12/12/2011
Published on : 12/12/2011
Exists online : False
Views : 366