Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"HTTP 400 Bad Request" error when you connect to an Exchange Server 2007 mailbox by using Outlook Web App


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You access a Microsoft Exchange Server 2007 mailbox for the first time by using Microsoft Outlook Web App (OWA).
  • A Microsoft Exchange Server 2010 Client Access server is a proxy for the Exchange 2007 server that hosts the mailbox.
  • You select the Language and Current time zone settings that you want, and then you click OK.
In this scenario, you may receive an error message that resembles the following:
HTTP Error 400.0 � Bad Request
Bad Request

Detailed Error Information

Module ManagedPipelineHandler
Notification ExecuteRequestHandler
Handler OwaEventHandler
Error Code 0x00000000

Additionally, you may receive an error message that resembles the following:
The page cannot be found

↑ Back to the top


Cause

This issue occurs if the sign-in and error language settings for OWA are not defined.

↑ Back to the top


Workaround

To work around this issue, configure the sign-in and error language settings for OWA. To do this, follow these steps:
  1. Start the Exchange Management Shell (EMS).
  2. At the command prompt, type the following cmdlet:

    Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -LogonAndErrorLanguage language_code

    In this command, language_code is a placeholder for the language code that you want. For example, type 1033 to set the sign-in and error language to English.
  3. Run the IISreset command to reset Internet Information Services (IIS). To do this, follow these steps:
    1. Click Start, and then type cmd in the Search programs and files box.
    2. Right-click cmd.exe in the Programs list, and then click Run as administrator.
    3. At the command prompt, copy or type the following command, and then press Enter:

      IISreset /noforce

↑ Back to the top


References

For more information about language codes and how to configure language settings for OWA, visit the following TechNet website:

↑ Back to the top


Keywords: KB2645573, kbtshoot, kbprb, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2645573
Revision : 1
Created on : 11/22/2011
Published on : 11/22/2011
Exists online : False
Views : 233