Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BUG: Code Download Error "0x8007000e" Occurs During a Component Download on Windows 95


View products that this article applies to.

Symptoms

When you download a component to a computer running Microsoft Windows 95 that does not have an active desktop installed, and then you specify a destination directory for the component with a path that contains either a space or more than eight characters, the code download error log displays the following error message:
Code Download Error: (hr = 8007000e) Not enough storage is available to complete this operation.

↑ Back to the top


Cause

This behavior occurs because the pointer to an item identifier list (PIDL) generation in the Shell32.dll file fails.

↑ Back to the top


Resolution

To resolve this behavior, install an active desktop. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
165695 How to Add or Remove Windows Desktop Update

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Steps to Reproduce Behavior

  1. On the computer running Windows 95, set the following destination directories in the registry:
    HKey_Local_Machine\Software\Microsoft\Windows\CurrentVersion\InternetSettings ActivexCache = "C:\DestinationDir"
    and
    HKey_Local_Machine\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ActiveX Cache "C:\DestinationDir"
  2. Create a component (either a .dll file or an .ocx file), and then wrap it into a Component.cab file.
  3. Create an HTML page, and then download the component that you created. Use the following code to create the HTML page:
    <HTML>
    <OBJECT ID="Component1"
    CLASSID="CLSID:xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx"
    CODEBASE="Component.CAB#version=x,x,x,x">
    </OBJECT>
    </HTML>
    					
  4. Open Microsoft Internet Explorer, and then navigate to the HTML page that you created. The code download error log displays the error message referenced in the "Symptoms" section of this article.
NOTE: When you call the CoGetClassObjectFromURL function to download the component that you created, you receive the same error message.

↑ Back to the top


References

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:
174653 How to Call CoGetClassObjectFromURL() in an MFC App
179420 PRB: CoGetClassObjectFromUrl Fails with "Generic Trust Failure"
252937 HOW TO: Find out more information about why code download failed
165695 How to Add or Remove Windows Desktop Update
For more information about developing Web-based solutions for Microsoft Internet Explorer, visit the following Microsoft Web sites:

↑ Back to the top


Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

↑ Back to the top


Keywords: KB261165, kbdownload, kbcode, kbbug

↑ Back to the top

Article Info
Article ID : 261165
Revision : 3
Created on : 5/11/2006
Published on : 5/11/2006
Exists online : False
Views : 475