Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"An error occurred accessing your FrontPage web files" error message when you create a new subweb or view Permissions in FrontPage 2000


View products that this article applies to.

Symptoms

In FrontPage, when you point to Security on the Tools menu and then click Permissions, or if you try to create a new subweb, you may receive the following error message:
An error occurred accessing your FrontPage web files. Authors - if authoring against a web server, please contact the webmaster for this server's site. WebMasters - please see the server's system log for more details.
In the Event Viewer on the server, the following error messages appear:
Microsoft FrontPage Server Extensions:
(OS Error #-1073741795 Message: exception occurred at 0x00c00982)
-and-
Microsoft FrontPage Server Extensions:
http://servername - Error #80002 Message: Unrecognized Windows exception (0xc000001d)
-and-
Microsoft FrontPage Server Extensions:
Received empty response from Microsoft FrontPage Server Extensions
You may also receive the following error message when you try to create a new project in Microsoft Visual InterDev:
An unexpected error occurs, accessing your web files.
See the server's System Event log for more information.

↑ Back to the top


Cause

These error messages appear because certain accounts in the Access Control Lists (ACLs) are deleted, or the accounts' friendly names are not resolvable from their security IDs (SIDs). This problem can occur if the Web server is removed from a domain after domain accounts are added to the permissions on the Web content. In this case, the Web server cannot contact the domain controller to resolve the SID.

↑ Back to the top


Resolution

To resolve this problem, you can rejoin the domain or disable accounts rather than deleting them.

↑ Back to the top


Workaround

If you cannot rejoin the domain, you must work around this problem by removing the accounts from the permissions. This usually involves resetting the permissions for the entire site. To do that, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Right-click Start and then click Explore.
  2. Locate the folder that contains your Web content, and then right-click that folder.
  3. Click Properties.
  4. Click the Security tab.
  5. Look for accounts that do not display a friendly name but instead display something like the following:
    S-1-5-21-124525095-708259637-1543119021-15767
  6. Select the unresolved accounts or groups, and then click Remove.

    Usually it is best to remove all accounts but leave the SYSTEM account with Full Control and the local Administrators group with Full Control.
  7. Select the Apply to all subfolders and files check box, and then click OK.
  8. Open the Web in FrontPage and re-add the accounts that you want to use. To do this, point to Security on the Tools menu, and then click Permissions.
  9. On the Users tab, set the browse access by selecting the appropriate button at the bottom of the dialog box.
  10. Click OK.
NOTE: If the preceding workaround does not resolve this problem, locate and delete unresolved SIDs in Users and Groups:
  1. Open Users and Groups as follows:
    • On a Microsoft Windows NT 4.0-based computer, from the Start menu, point to Programs, point to Administrative Tools, and then click Users and Groups.
    • On a Windows 2000-based computer, from the Start menu, point to Programs, point to Administrative Tools, and then click Computer Management. Users and Groups appears as a node under System Tools.
  2. Open each group to see the list of its members, and delete any unresolved SIDs.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


More information

Problems caused by unresolved accounts can appear in many ways, not just in FrontPage. To determine whether you have unresolved accounts in file permissions, follow these steps:
  1. Right-click Start and then click Explore.
  2. Navigate to the folder that contains your Web content, and right-click that folder.
  3. Click Properties.
  4. Click the Security tab. Look for accounts that do not display a friendly name but instead display something like the following:
    S-1-5-21-124525095-708259637-1543119021-15767
    If you see something like this identifier, there is a problem resolving the name for that account. It is possible that the domain is down, or that the account was deleted rather than disabled.
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
277752 Security Identifiers for Built-In Groups Are Unresolved When Modifying Group Policy

↑ Back to the top


Keywords: KB260159, kbpending, kberrmsg, kbprb, , kbpermissions, kbaccounts

↑ Back to the top

Article Info
Article ID : 260159
Revision : 3
Created on : 2/19/2007
Published on : 2/19/2007
Exists online : False
Views : 355