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PRB: Cannot Enumerate OLE DB Providers


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This article was previously published under Q260145
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

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Symptoms

When you attempt to create a link to an OLE DB datasource by using the Universal Data Link (UDL) wizard on the desktop, the import\export wizard, or the Data Transformation Services (DTS) designer, the available OLE DB providers are not enumerated.

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Cause

The problem can be caused by a bad entry in the registry at HKEY_CLASSES_ROOT\CLSID. The bad entry may resemble the following (but much longer):
000????????????????????????????????
The entry is easy to find because is the first entry in the key.

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Resolution

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry:
    HKEY_CLASSES_ROOT\CLSID\000<<<<<<<<<<<<<<<<<<<...<<<<<<
    							
    NOTE: In this registry key, the "..." represents about 180 boxes. The number of these characters is not important. If you see an entry that resembles this, it is probably the problem entry.
  3. On the Edit menu, click Delete, and then click OK.
  4. Quit Registry Editor.

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Keywords: KB260145, kbprovider, kbprb, kbdatabase

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Article Info
Article ID : 260145
Revision : 3
Created on : 5/10/2003
Published on : 5/10/2003
Exists online : False
Views : 333