Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Microsoft Exchange Information Store service may crash after you run the Test-ExchangeSearch cmdlet in an Exchange Server 2007 environment


View products that this article applies to.

Symptoms

Consider the following scenario. You enable Mailbox Access Auditing in a Microsoft Exchange Server 2007 environment. You run the Test-ExchangeSearch cmdlet to test the search function. In this scenario, the Microsoft Exchange Information Store service may crash. Additionally, the following error messages are logged in Application log:

Time: <Time>
ID: 4999
Level: Error
Source: MSExchange Common
Machine: <Computer>
Message: Watson report about to be sent to dw20.exe for process id: <Process ID>, with parameters: E12N, <Build Type>, <Version Number>, store.exe, store.exe, <xxxx>, c0000005, <xxxx> , <Version number>. ErrorReportingEnabled: False

Time: <Time>
ID: 9659
Level: Error
Source: MSExchangeIS
Machine: <Computer>
Message: The Microsoft Exchange Information Store encountered an unexpected exception 0xC0000005 at address <Address> while processing a request for user <User>.

Time: <Time>
ID: 1000
Level: Error
Source: Application Error
Machine: <Computer>
Message: Faulting application store.exe, version <Version>, time stamp <Time Stamp>, faulting module store.exe, version <Version>, time stamp <Time Stamp>, exception code 0xc0000005, fault offset <Offset>,
process id <Process ID>, application start time <Time>.
Note When this issue occurs, users cannot access their mailboxes.

↑ Back to the top


Cause

This issue occurs because of an access violation when Mailbox Access Auditing accesses deleted temporary folders or messages that are created by using the Test-ExchangeSearch cmdlet. This behavior causes the Microsoft Exchange Information Store service to crash.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2608656 Description of Update Rollup 6 for Exchange Server 2007 Service Pack 3

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about Mailbox Access Auditing for Exchange Server 2007 organizations, visit the following Microsoft website:
For more information about the Test-ExchangeSearch cmdlet, visit the following Microsoft website:

↑ Back to the top


Keywords: KB2572010, kbexpertiseinter, kbsurveynew, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 2572010
Revision : 1
Created on : 1/25/2012
Published on : 1/25/2012
Exists online : False
Views : 333