Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Store.exe process may consume excessive CPU resources and memory resources intermittently when a user opens a calendar item by using OWA in an Exchange Server 2007 SP3 environment


View products that this article applies to.

Symptoms

When a user opens a calendar item by using Outlook Web Access (OWA) in a Microsoft Exchange Server 2007 Service Pack 3 (SP3) environment, the Store.exe process may consume excessive CPU resources on the Exchange server intermittently. Additionally, the memory used by the Store.exe process increases significantly. Additionally, the following event is logged in Application log:

Event Type: Error
Event Source: MSExchangeIS
Event Category: Performance
Event ID: 9582
Description:
The virtual memory necessary to run your Exchange server is fragmented in such a way that normal operation may begin to fail. It is highly recommended that you restart all Exchange services to correct this issue.
Note When this issue occurs, the Exchange server may stop responding to all client requests.

↑ Back to the top


Cause

This issue occurs because the calendar item has exceptions and each exception has attachments that are also iCalendar (iCal) messages. This causes the Store.exe process to fall into an infinite loop.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2602324 Description of Update Rollup 5 for Exchange Server 2007 Service Pack 3
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

After you install the hotfix package, follow these steps to restrict the number of the attachments:
  1. Click Start
    , type regedit in the Start Search box, and then press ENTER.
  2. Locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\Software\Microsoft\EXCDO\Parameters
  3. Click Edit, point to New, and then click DWORDValue, type Limit Total Attachments, and then press ENTER.
  4. Right-click Limit Total Attachments, and then click Modify.
  5. In the Value data box, type <number>, and then click OK.
  6. Exit Registry Editor.
Notes
  • The Limit Total Attachments value can be any number based on your environment. If the value is 0, there is no number of attachment limit.
  • You must restart the Microsoft Exchange Information Store service after you change the registry entry.
  • After you type registry entry, and a user tries to open a calendar item that includes too many attachments that exceed the predefined number, the following event is logged in Application log:
    Event Type: Error
    Event Source: EXCDO
    Event Category: General
    Event ID: 8273
    Description:
    Exceeded the limitation of attachment per calendar item during converting. Mailbox <mailbox address>, item <the path of the calendar item>.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB2557304, kbexpertiseinter, kbsurveynew, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 2557304
Revision : 1
Created on : 9/22/2011
Published on : 9/22/2011
Exists online : False
Views : 325