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The handle count and "Virtual Bytes" for the Windows Event Log service keep increasing in Windows Server 2008 or in Windows Vista when you refresh scheduled task history events


View products that this article applies to.

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

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Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2008 or Windows Vista.
  • You open a task in the Task Scheduler Microsoft Management Console (MMC) snap-in window, and you click the History tab.
  • You use one of the following methods to update history events:
    • You right-click the upper panel of the task and then select Refresh.
    • You right-click Task Scheduler Library in the left panel and then select Refresh.
In this scenario, the handle count and the Virtual Bytes for the Windows event log service keep increasing. Over time, the user mode virtual address space is used up.

When user mode virtual address space is used up, you may experience one or more of the following symptoms:
  • Event Viewer cannot display events, and you receive an error message that resembles the following:
    no more threads can be created in the system
  • When viewing the task history, you receive an error message that resembles the following:
    The user account does not have permission to view task history on this computer
  • The Ipconfig.exe utility cannot display network adapter configuration information.
  • You cannot establish terminal server session to the computer.
  • You cannot access shared files or shared printers on the computer.
Note
  • This issue does not occur if you right-click any history event on the History tab and then select Refresh.
  • The Windows event log service runs in a Svchost.exe process. You can run the tasklist -svc command to determine which Svchost.exe process the service runs in.

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Cause

This issue occurs because the Task Scheduler MMC snap-in does not release allocated memory resource in a timely manner. Therefore, user mode virtual address space is used up if you frequently update scheduled task history events by using the methods that are described in the "Symptoms" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791

How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849

How to obtain the latest service pack for Windows Server 2008

Registry information

You do not have to make any changes to the registry to use this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system to which each hotfix applies.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6002.225473,375,10414-Dec-201023:10x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6002.225473,375,10414-Dec-201023:06x86
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Miguicontrols.dll6.0.6002.225473,375,10414-Dec-201023:01x86

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Workaround

Workaround for Windows Vista and for Windows Server 2008

To work around the issue, you can restart the Task Scheduler and reopen the Task Scheduler MMC snap-in window.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information



For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684

Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameMsil_miguicontrols_31bf3856ad364e35_6.0.6002.22547_none_b094b6e152f91531.manifest
File versionNot applicable
File size3,999
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,415
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
File nameX86_3c9b3262d0eef42f72994e69fed4b40e_31bf3856ad364e35_6.0.6002.22547_none_aafc99b3445ca9b8.manifest
File versionNot applicable
File size684
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_3c9b3262d0eef42f72994e69fed4b40e_31bf3856ad364e35_6.0.6002.22547_none_071b3536fcba1aee.manifest
File versionNot applicable
File size686
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
File nameMsil_miguicontrols_31bf3856ad364e35_6.0.6002.22547_none_b094b6e152f91531.manifest
File versionNot applicable
File size3,999
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,433
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_3c9b3262d0eef42f72994e69fed4b40e_31bf3856ad364e35_6.0.6002.22547_none_aafe3da9445ab2b4.manifest
File versionNot applicable
File size685
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
File nameMsil_miguicontrols_31bf3856ad364e35_6.0.6002.22547_none_b094b6e152f91531.manifest
File versionNot applicable
File size3,999
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,593
Date (UTC)14-Dec-2010
Time (UTC)23:15
PlatformNot applicable

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Keywords: kb, kbmdd, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter

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Article Info
Article ID : 2482438
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 336