Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Error Message 0xc002054b: The Specified Domain Does Not Exist


View products that this article applies to.

This article was previously published under Q247588
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you access the Permissions tab by using the Exchange Server Administrator program, the following error message is displayed:
The specified domain did not exist.
Microsoft Windows NT
ID no: 0xc002054b
After you click OK, the Permissions tab has no information displayed.

↑ Back to the top


Cause

This problem is caused by an invalid domain entry in the CachePrimaryDomain value in the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
You can also view this invalid entry by using the Exchange Server Administrator program; on the Tools menu, click Options, click Permissions, and then click Default Windows NT domain.

↑ Back to the top


Resolution

To resolve this problem, you need to modify the registry key to reflect a valid domain.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
1.Start the Registry Editor (Regedt32.exe).
2.Locate the CachePrimaryDomain value under the following key in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
NOTE: The above registry key is one path; it has been wrapped for readability.
3.On the Edit menu, click String , type a valid Microsoft Windows NT domain name, and then click OK.
4.Quit the Registry Editor.
NOTE: If you change this entry by using the Exchange Server Administrator program, you do NOT modify this registry entry. If you return to the Permissions tab, the entry reverts to the invalid registry entry. You must modify the registry value.

↑ Back to the top


Keywords: KB247588, kbprb, kbnofix

↑ Back to the top

Article Info
Article ID : 247588
Revision : 5
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 276