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Virtual Disk Service (VDS) crashes while the service is shutting down in Windows Server 2008 or Windows Vista


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2008 or Windows Vista, Virtual Disk Service (VDS) crashes while the service is shutting down.

Additionally, an error that resembles the following entry is logged in the System log:

Log Name: System
Source: Virtual Disk Service
Date: <date>
Event ID: 1
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <computer name>
Description: Unexpected failure. Error code: exception code


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Cause

This problem occurs because of a lack of synchronization when there are lots of incoming plug and play work requests for VDS while the service is shutting down.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem that is described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 with Service Pack 2 (SP2) or Windows Vista with SP2.

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or to both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately�in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintaining the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Vds.exe6.0.6002.22527386,04818-Nov-201016:48x86
Vdsldr.exe6.0.6002.2252719,96818-Nov-201016:48x86
Vdsutil.dll6.0.6002.22527128,00018-Nov-201018:51x86
Vds_ps.dll6.0.6002.2252737,88818-Nov-201018:51x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Vds.exe6.0.6002.22527455,68018-Nov-201017:16x64
Vdsldr.exe6.0.6002.2252722,52818-Nov-201017:16x64
Vdsutil.dll6.0.6002.22527157,69618-Nov-201019:10x64
Vds_ps.dll6.0.6002.2252797,28018-Nov-201019:10x64
Vdsldr.exe6.0.6002.2252719,96818-Nov-201016:48x86
Vdsutil.dll6.0.6002.22527128,00018-Nov-201018:51x86
Vds_ps.dll6.0.6002.2252737,88818-Nov-201018:51x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information


For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameX86_49681512ddc2344ecc1ce05ed550b32f_31bf3856ad364e35_6.0.6002.22527_none_302d843d14fc67e8.manifest
File versionNot applicable
File size706
Date (UTC)19-Nov-2010
Time (UTC)06:32
PlatformNot applicable
File nameX86_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.0.6002.22527_none_6d4c50cb10fc667b.manifest
File versionNot applicable
File size99,880
Date (UTC)18-Nov-2010
Time (UTC)19:09
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_45e7b7726b8fa298a8f92a6272d6fe49_31bf3856ad364e35_6.0.6002.22527_none_6508f5826cc25c6e.manifest
File versionNot applicable
File size1,062
Date (UTC)19-Nov-2010
Time (UTC)06:32
PlatformNot applicable
File nameAmd64_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.0.6002.22527_none_c96aec4ec959d7b1.manifest
File versionNot applicable
File size99,944
Date (UTC)18-Nov-2010
Time (UTC)19:27
PlatformNot applicable
File nameWow64_microsoft-windows-virtualdiskservice_31bf3856ad364e35_6.0.6002.22527_none_d3bf96a0fdba99ac.manifest
File versionNot applicable
File size98,595
Date (UTC)18-Nov-2010
Time (UTC)18:55
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbHotfixServer, kbfix, kbsurveynew, kbexpertiseadvanced, KB2465972

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Article Info
Article ID : 2465972
Revision : 3
Created on : 6/21/2014
Published on : 6/21/2014
Exists online : False
Views : 280