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Error message: "No transport provider was available"


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Symptoms

When you use a simple Messaging Application Programming Interface (MAPI) profile, you may receive the following error message:
No transport provider was available

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Cause

Your profile contains both of the following services:
  • An internet e-mail service such as Simple Mail Transport Protocol (SMTP) or Post Office Protocol 3 (POP3)
  • Microsoft Exchange Server service
This behavior is due to the way that MAPI handles SMTP address resolution. While this configuration may appear to work, the resolution order, and therefore the ability to resolve SMTP addresses correctly, may not work. This behavior becomes more noticeable in complex organizations. This configuration also causes issues when you connect to a computer that is running Microsoft Exchange Server.

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Workaround

To work around this behavior, create two different profiles. One profile is for the Internet mail service, and one profile is for the Exchange Server service.

For more informationabout how to set up Outlook profiles and how to configure Outlook to prompt you for a profile, click the following article number to view the article in the Microsoft Knowledge Base:
195478 Description of user profiles and information services in Outlook 2000 with the Corporate or Workgroup option
182159 OL98: (CW) User Profiles and Information Services
162203 OL97: User Profiles and Information Services
When you set up two different profiles, you must quit Outlook before you can switch to the other profile.

Another way to work around this behavior is to use Outlook Express for POP3 or SMTP internet e-mail services, and to use Outlook when you connect to a computer that is running Exchange Server.

This information applies to using Microsoft Mail in a profile with Exchange and/or Internet Mail Service. In addition, Microsoft recommends that you have a separate profile for the Microsoft Mail service.

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More information

If you install Internet Mail Service (IMS) on a computer that is running Exchange Server, mail is automatically sent using Exchange Server. The SMTP server that you specify as your Internet e-mail account is not used.

The Outlook program, acting as the Exchange client software, sends an NspiResolveNames request to Exchange Server. If you install IMS, Exchange Server attempts to handle the message even if you have not correctly configured it to send Internet e-mail. In such a situation, a non-delivery report (NDR) is received.

There is no client resolution available for this situation other than the use of separate user profiles for Outlook. Configure Exchange to send SMTP mail by installing IMS, or to use another e-mail program to send Internet e-mail.

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Keywords: KB245446, kbprb

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Article Info
Article ID : 245446
Revision : 9
Created on : 1/25/2007
Published on : 1/25/2007
Exists online : False
Views : 427