Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive a connection error message when you create a database connection or locate a database


View products that this article applies to.

Symptoms

When you try to create a database connection in a FrontPage Web, you may receive one of the following error messages:
Server error: Unable to retrieve the list of record sources from a database using the connection string:

DSN=fpdb;DRIVER={Microsoft Access Driver (*.mdb)}.

The following error message comes from the database driver software; it may appear in a different language depending on how the driver is configured.
-------------------------------------------------------

Source: ADO
Number: -2146824584 (0x800a0e78)
-or-
Server error: Unable to retrieve the list of record sources from a database using the connection string:

DRIVER={Microsoft Access Driver (*.mdb)};DBQ=URL=fpdb/new_page_1.mdb.

The following error message comes from the database driver software; it may appear in a different language depending on how the driver is configured.
-------------------------------------------------------

Source: ADO
Number: -2146824584 (0x800a0e78)
If you locate an Active Server Pages (ASP) page with a database region, you receive the following error message in the browser:
Database Results Error
[Microsoft][ODBC Microsoft Access Driver] The Microsoft Jet database engine cannot open the file '(unknown)'. It is already opened exclusively by another user, or you need permission to view its data.

↑ Back to the top


Cause

This problem occurs because the Microsoft Jet Database Engine is trying to write temporary files in your Winnt folder or Winnt\System32 folder while the account accesses the Web. When you are authoring the Web, the account is the logged-on user. When you are browsing the Web, the account is the Internet Guest (IUSR_machinename) account.

↑ Back to the top


Resolution

To resolve this issue, create TEMP and TMP system environment variables on the server. To do this, follow the steps for your operating system.

Windows 2000

  1. Right-click My Computer on your desktop, and then click Properties.
  2. Click the Advanced tab, and then click the Environment Variables button.
  3. Add the TEMP variable. To do this, follow these steps:
    1. Under System variables, click the New button.
    2. In the Variable Name text box, type TEMP.
    3. In the Variable Value text box, type a location for your temporary folder. For example, you can use C:\TEMP if that path exists on your computer.
    4. Click OK to add the variable to your computer.
  4. Repeat steps a through d to add a TMP environment variable.
  5. Click OK to close the Environment Variables dialog.
  6. Click OK to close the System Properties dialog box.

Windows NT 4.0

  1. Right-click My Computer on your desktop, and then click Properties.
  2. Click the Environment tab.
  3. Under System Variables, click an existing variable.
  4. Add the TEMP variable. to do this, follow these steps:
    1. Delete the value in the Variable text box, and then type TEMP.
    2. Delete the value in the Value text box, and then type a location for your temporary folder. For example, you can use C:\TEMP if that path exists on your computer.
    3. Click Set to add the variable to your computer.
  5. Repeat the steps a through c to add a TMP environment variable.
  6. Click OK to close the System Properties dialog.
  7. Restart your computer for the changes to take effect.

↑ Back to the top


More information

The Microsoft Jet Database Engine uses temporary files when you work with Microsoft Access databases. The temporary folder that the Microsoft Access database uses requires that access be granted to the Internet Guest (IUSR_machinename) account. If the temporary folders are not defined in the system variables for the computer, the Microsoft Jet Database Engine tries to create and modify temporary files in your WINNT or WINNT\System32 folder. For security reasons, the Internet Guest probably does not have permissions to create or modify files in those paths.

For additional information about related error messages that you may receive when you work with the Microsoft Jet Database Engine, click the following article numbers to view the articles in the Microsoft Knowledge Base:
251254 "Disk or network error" or "Unspecified error" returned when using Jet
253604 Microsoft Access 97 database connectivity fails in Active Server Pages

↑ Back to the top


Keywords: KB243331, kbprb, kberrmsg, kbdatabase, kbasp

↑ Back to the top

Article Info
Article ID : 243331
Revision : 2
Created on : 8/2/2004
Published on : 8/2/2004
Exists online : False
Views : 370