Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Office Communicator cannot place calls to the Exchange Unified Messaging Auto Attendant


View products that this article applies to.

Symptoms

Office Communicator cannot place calls to the Exchange Unified Messaging (EUM) Auto Attendant (AA).

↑ Back to the top


Cause

This issue occurs because the EUM AA that is associated with the Office Communications Server (OCS) pool was created by using a display name that contains spaces.

↑ Back to the top


Resolution

To resolve this issue, the following actions must be taken:
  • The EUM AA that is associated with the OCS pool that has a display name that contains space characters must be removed and then replaced with an EUM AA that has a display name that contains no space characters.
  • The configuration steps that are needed to integrate the EUM AA with the OCS pool must be followed.
To do this, you will make changes from the following two locations:
  • Exchange Management Console (EMC) or from the Exchange Management Shell (EMS)
  • Communications Server front-end server
To remove and then replace the EUM AA, use the following instructions:

Managing UM Auto Attendants
http://technet.microsoft.com/en-us/library/bb124501(EXCHG.140).aspx

After the EUM AA is re-created, you can use one the following Exchange PowerShell cmdlet from the EMS to associate the EUM Dial plan with the Office Communications Server pool object:

Exchange 2007 - %Program Files%\...\Scripts>.\ExchUcUtil.ps1

Exchange 2010 - %Program Files%\...\Scripts>.\v14\ExchUcUtil.ps1

To make sure that the new EUM AA is recognized by the OCS pool infrastructure, follow these steps:

  1. On an OCS Pool Front End Server, open Windows Explorer, and then browse to the following folder:

    %Program Files%\Common Files\Microsoft Office Communications Server 2007\Support\
  2. Double-click the OcsUmUtil.exe file to start it.
  3. In the Exchange UM Integration Utility dialog box, click Load Data.
  4. From the Exchange UM Dial Plan Forest drop-down selector, select the forest domain that is hosting the OCS and EUM infrastructure.
  5. Use the Add or Edit button in the Exchange UM Integration Utility dialog box to configure the new EUM AA.
  6. If the EUM dial plan for the OCS pool supports a System Attendant (SA) configuration, make sure that the SA configuration is added together with the EUM AA configuration in the Exchange UM Integration Utility dialog box.
  7. When the configuration is complete, close the Exchange UM Integration Utility dialog box.



↑ Back to the top


More information

The error message that the OC client provides when the call to the EUM AA fails seems to be nonessential. To confirm that this is the issue that is occurring with the OC client, follow these steps:
  1. Download the OCS 2007 R2 Resource Kit Tools, and then install them onto the Windows client that hosts the OC client.
  2. On the OC client that is providing the error, turn on the client logging feature that is available on the General tab through the OC client's Tools, Options menu.
  3. Click to select the Turn logging on in Communicator check box.
  4. Click OK.
  5. Use the OC client to dial in to the EUM AA to re-create the error message.
  6. Exit the OC client.
  7. Use Windows Explorer on the Windows client to locate the following folder:

    %Program Files%\Office Communications Server 2007 R2\ResKit\Tracing
  8. Double-click the Snooper.exe file to start the Snooper SIP capture utility.
  9. Use Snooper to locate and then open the following file:

    %userprofile%\Tracing\communicator-uccpapi-0.uccapilog
  10. Use the search feature of Snooper.exe to search for the following string:

    "The application specified an invalid request-uri"
  11. The results of the search should resemble the following SIP response packet information:

Trace-Correlation-Id: 3157480233
Instance-Id: 000046EA
Direction: outgoing;source="local"
Peer: 10.0.0.122:49382
Message-Type: response
Start-Line: SIP/2.0 400 Bad request
From: "Thomas Anderson"<sip:thomas@contoso.com>;tag=d188533aa4;epid=d01f1abc1f
To: <sip:+59999@contoso.com;user=phone>;tag=1B2988822268927BC8E1B9B1FA6A0096
CSeq: 1 INVITE
Call-ID: 6260c8dc7bf74c68b02287145d211093
Authentication-Info: TLS-DSK qop="auth", opaque="F952C736", srand="54B4DF14", snum="15",
rspauth="8f86570efd6df642296ea281242bdc684db93fb1", targetname="ocsserver.contoso.com", realm="SIP Communications
Service", version=3
Via: SIP/2.0/TLS 10.0.0.122:49382;ms-received-port=49382;ms-received-cid=1C2C00
ms-diagnostics: 1;reason="Service Unavailable";AppUri="http%3A%2F%2Fwww.microsoft.com%2FLCS
%2FExumRouting";reason="The application specified an invalid request-uri";source="ocsserver.contoso.com"
Server: RTC/.0
Content-Length: 0
Message-Body: �
$$end_record

↑ Back to the top


Keywords: KB2431925, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2431925
Revision : 2
Created on : 9/3/2013
Published on : 9/3/2013
Exists online : False
Views : 471