Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Timing and scheduling issues after a daylight saving time update or time zone update


View products that this article applies to.

Symptoms

The start dates and the end dates for daylight saving time (DST) in many countries change from year to year. Additionally, some countries may change their DST recognition policy or may change the local time offset from Coordinated Universal Time (UTC). In this scenario, some schedules and some applications that depend on date and time calculations may have a problem.

↑ Back to the top


Cause

This issue occurs because of incorrect or missing time zone information, which can occur if the latest Windows Daylight Saving Time Cumulative Update has not been applied.

↑ Back to the top


Resolution

To fix this problem, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756How to back up and restore the registry in Windows
  1. Import the applicable TZI and annual rules into the registry under the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones
    Note If registry value does not exist, import the English string into the registry under the following registry subkey for the "Non-MUI_*" string (for example: "Display", "Dlt", "Std" registry keys):
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones
  2. Run the appropriate command for your operating system:
    Windows XP and Windows Server 2003
    Tzchange.exe /w 2147483648

    Windows Vista, Windows 7, Windows Server 2008 and Windows Server 2008 R2
    %Windows%\servicing\GC32\tzupd.exe


↑ Back to the top


More Information

If these steps do not resolve your issue, see the manual steps listed in the following Knowledge Base article:
914387 How to configure daylight saving time for Microsoft Windows operating systems
Note Follow the steps listed in the section titled “Manually configure daylight saving time dates by modifying an existing time zone”

↑ Back to the top


Applies to:

↑ Back to the top

Keywords: kb, kbtshoot, kbprb, kbexpertisebeginner, kbexpertiseinter, kbsurveynew, kbmatsfixme

↑ Back to the top

Article Info
Article ID : 2400550
Revision : 3
Created on : 4/18/2018
Published on : 4/19/2018
Exists online : False
Views : 365