Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

OFF2000: PNG Files from Adobe Photoshop Appear Incorrectly


View products that this article applies to.

This article was previously published under Q238559

↑ Back to the top


Symptoms

If you save an Adobe Photoshop image as a PNG (Portable Network Graphics) file and then insert the PNG file into an Office 2000 application, the PNG file may appear too dark or too light compared with the original Photoshop image.

↑ Back to the top


Cause

The Adobe Photoshop PNG export filter incorrectly doubles the Gamma value of exported picture files.

↑ Back to the top


Resolution

To resolve this issue, you must export the PNG file from Photoshop again, or use the Microsoft Office Picture toolbar to lighten or darken the image.

Method 1

  1. Inside your Office application, click the PNG to select it.
  2. If the Picture toolbar is not visible, point to Toolbars on the View menu, and make sure that Picture is selected.
  3. Use the More Brightness and Less Brightness buttons on the Picture toolbar to adjust the brightness of the PNG picture.

Method 2

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
  1. Before you export the PNG file inside Adobe Photoshop, point to Color Settings on the File menu, then click RGB Setup.
  2. In the Gamma area, change the Gamma correction value to exactly half of the displayed value. Click OK.
  3. On the File menu, click Save Copy As, and then resave your PNG file with a new name. The new PNG will appear correctly in Microsoft Office.

↑ Back to the top


Status

This problem occurs when you use Microsoft Office version 2000 and Adobe Photoshop version 5.

↑ Back to the top


More information

Gamma correction is a formula or method designed to maintain the lightness or darkness of a picture across multiple output devices (usually computer screens). There are many different methods and types of Gamma correction.

Essentially, when a picture with an assigned Gamma value is displayed using hardware or software that supports Gamma correction, the picture is corrected to more closely represent the lightness or darkness that it possessed in the original device or application.

When Gamma correction is applied to a PNG picture, some applications ignore the Gamma correction information. Microsoft FrontPage and Microsoft PhotoDraw ignore the Gamma correction information generated by PNG files. (Note that while FrontPage ignores the Gamma correction information, Internet Explorer 5 does not. Therefore, pictures that look okay inside FrontPage may appear too light or too dark when previewed in your browser.)

↑ Back to the top


Keywords: KB238559, kbnofix, kbbug

↑ Back to the top

Article Info
Article ID : 238559
Revision : 3
Created on : 11/25/2003
Published on : 11/25/2003
Exists online : False
Views : 318