Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Various MSExchangeRepl 2163 events seen on Microsoft Exchange Server 2007/2010


View products that this article applies to.

Symptoms

The following error�is seen on a Microsoft Exchange 2007 or Microsoft Exchange 2010 server:

Source: MSExchangeRepl
Event ID: 2163
Task Category: Service
Level: Error
Description:
The log copier for database 'DB' received an error from the source server 'server': File 'Drive:\Logs\#######.log' could not be opened. The process cannot access the file because it is being used by another process The copier will automatically retry after a short delay.

↑ Back to the top


Cause

These events will be seen when the log copier component attempts to copy a log from�a source that is not yet closed/flushed. When�the log copier retries again, once the log is closed, it succeeds.

These errors are occuring due to the current design for how we �poll� the active copy for new logs, instead of waiting for the source server to close/flush/notify that a new log is available, we instead poll for new log files that have been created and attempt to copy them over.

↑ Back to the top


Resolution

These errors do not affect the funtionality of the�log�copy process and�can be safely ignored.

Please note: If you see errors for the�same logs failing the copy process over and over on each retry, this would be an indication of another issue and needs to be investigated.

↑ Back to the top


Keywords: KB2288693, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2288693
Revision : 1
Created on : 7/21/2010
Published on : 7/21/2010
Exists online : False
Views : 335