Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Exchange Information Store service stops responding when you perform a search operation on an Exchange Server 2007 mailbox in Outlook


View products that this article applies to.

Symptoms

In a Microsoft Exchange Server 2007 environment, the Microsoft Exchange Information Store service (Store.exe) stops responding when�a client performs a search operation in Microsoft Office Outlook. At the same time, all mail flow to the server stalls and no users can connect to the server.�To recover from this issue, you have to perform one of the following actions:
  1. Restart the Microsoft Exchange Information Store service.
  2. Failover to another Exchange server node.
  3. Restart the server.


↑ Back to the top


Cause

The issue occurs because of a deadlock situation between both threads in the Store.exe process. One thread performs sorting operations and the other thread performs notification operations.

↑ Back to the top


Resolution

To resolve this issue, install the following update rollup:
2407025� Description of Update Rollup 2 for Exchange Server 2007 Service Pack 3

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB2265306, kbsurveynew, kbhotfixrollup, kbexpertiseinter, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 2265306
Revision : 2
Created on : 12/31/2010
Published on : 12/31/2010
Exists online : False
Views : 384