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Automatic resolution policy for an offline file synchronization conflict does not work if the "keep all changes" setting is enabled in Windows Vista, Windows Server 2008, Windows 7 or Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:

  • You set up an offline file synchronization partnership between a network share and some computers that are running one of the following operating systems:
    • Windows Vista
    • Windows Server 2008
    • Windows 7
    • Windows Server 2008 R2
  • You set an automatic resolution policy to resolve conflict in the synchronization process.
  • You configure the policy to "keep all changes" when a conflict occurs.

    Note To do this, follow these steps:

    1. Click Start, type regedit in the Start Search box, and then press ENTER.

    2. Locate and then click the following registry subkey:

    HKEY_LOAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache
    3. On the Edit menu, point to New, and then click Key. Type SyncConflictHandling, and then press ENTER.

    4. Right-click SyncConflictHandling, point to New, and then click Expandable String Value. Type the path of the network share as the value name.
      
    Note If you use an expandable string (such as %appdata%), it must resolve to a UNC path and not to a local path. Otherwise, you may receive an "incorrect parameter" error during each sync.

    5. Right-click the value name, and then click Modify. In the Value data box, type 3, and then click OK.
  • You update a file at multiple locations when the file is offline.
  • You conduct a synchronization operation for the network share. It triggers a conflict in the synchronization process when it synchronizes the file.
In this scenario, the automatic resolution policy does not keep all changes for the conflicted file. Additionally, you receive an error message that resembles the following:

Cannot create a file when that file already exists.

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Cause

The automatic resolution policy does not generate new file names for the conflicted file correctly when the conflict occurs in the synchronization process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:

935791 How to obtain the latest Windows Vista service pack

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Cscsvc.dll6.0.6002.22426494,08017-Jun-201018:25x86
Microsoft-windows-offlinefiles.mofNot applicable1,93103-Apr-200922:43Not applicable
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Cscsvc.dll6.0.6002.22426608,76817-Jun-201018:18x64
Microsoft-windows-offlinefiles.mofNot applicable1,93103-Apr-200921:07Not applicable
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    1.
    22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Cscsvc.dll6.1.7601.22078549,88803-Aug-201217:40x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Cscsvc.dll6.1.7601.22078696,83203-Aug-201218:21x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about OFFLINEFILES_SYNC_CONFLICT_RESOLVE enumeration, visit the following Microsoft website: For more information about new features for offline files in Windows Vista, visit the following Microsoft website: For more information about changes to offline files in Windows Vista, visit the following Microsoft website: For some frequently asked questions about how to resolve synchronization conflicts, visit the following Microsoft website:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size16,924
Date (UTC)18-Jun-2010
Time (UTC)05:03
PlatformNot applicable
File nameX86_microsoft-windows-offlinefiles-service_31bf3856ad364e35_6.0.6002.22426_none_0c340e0577aef83e.manifest
File versionNot applicable
File size39,150
Date (UTC)17-Jun-2010
Time (UTC)20:18
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_microsoft-windows-offlinefiles-service_31bf3856ad364e35_6.0.6002.22426_none_6852a989300c6974.manifest
File versionNot applicable
File size39,186
Date (UTC)17-Jun-2010
Time (UTC)20:02
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size17,088
Date (UTC)18-Jun-2010
Time (UTC)05:03
PlatformNot applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size15,610
Date (UTC)23-Aug-2012
Time (UTC)11:12
PlatformNot Applicable
File nameX86_microsoft-windows-offlinefiles-service_31bf3856ad364e35_6.1.7601.22078_none_0c279834d8ed3508.manifest
File versionNot Applicable
File size56,703
Date (UTC)03-Aug-2012
Time (UTC)18:24
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_microsoft-windows-offlinefiles-service_31bf3856ad364e35_6.1.7601.22078_none_684633b8914aa63e.manifest
File versionNot Applicable
File size56,710
Date (UTC)03-Aug-2012
Time (UTC)19:04
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size15,766
Date (UTC)23-Aug-2012
Time (UTC)11:12
PlatformNot Applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew

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Article Info
Article ID : 2189014
Revision : 1
Created on : 1/7/2017
Published on : 2/16/2013
Exists online : False
Views : 380