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It takes a long time to complete a batch of print jobs on a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Vista or Windows Server 2008.
  • You run a batch job to print many printouts. For example, you print 1000 printouts.
  • These printouts meet the following conditions:
    • They are printed to files.
    • The size of each printout is small.
    • Each printout is usually finished within 1 second.
In this scenario, it takes�longer to complete the batch job than to complete the batch job on a computer that is running Windows XP or Windows Server 2003. For example, it takes 10 minutes to complete the batch job on a computer that is running Windows XP or Windows Server 2003. However, it takes 100 minutes to complete the batch job on a computer that is running Windows Vista or Windows Server 2008.�

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Cause

This issue occurs because the print spooler waits for a hardcoded time (1 second) after each job in the batch is printed to�a file. This behavior causes the issue that is described in the "Symptoms" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 SP2 on the computer. For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Winspool.drv6.0.6002.22417258,04803-Jun-201015:58Not applicable
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatformService branch
Winspool.drv6.0.6002.22417342,52803-Jun-201016:13Not applicableAMD64_MICROSOFT-WINDOWS-P..TING-SPOOLER-CLIENT_31BF3856AD364E35_6.0.6002.22417_NONE_F1B8DDD3E750F2E6
Winspool.drv6.0.6002.22417258,04803-Jun-201015:58Not applicableX86_MICROSOFT-WINDOWS-P..TING-SPOOLER-CLIENT_31BF3856AD364E35_6.0.6002.22417_NONE_959A42502EF381B0
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformService branch
Winspool.drv6.0.6002.22417659,96803-Jun-201015:55Not applicableIA64_MICROSOFT-WINDOWS-P..TING-SPOOLER-CLIENT_31BF3856AD364E35_6.0.6002.22417_NONE_959BE6462EF18AAC
Winspool.drv6.0.6002.22417258,04803-Jun-201015:58Not applicableX86_MICROSOFT-WINDOWS-P..TING-SPOOLER-CLIENT_31BF3856AD364E35_6.0.6002.22417_NONE_959A42502EF381B0

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about functions in the print spooler application program interface (API), visit the following Microsoft Developer Network (MSDN) website: For more information about functions in the EndDoc function, visit the following MSDN website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size3,269
Date (UTC)04-Jun-2010
Time (UTC)14:52
PlatformNot applicable
File nameX86_3ed4127b528e666883a9bbe7584b3750_31bf3856ad364e35_6.0.6002.22417_none_bb22fc272cf5662c.manifest
File versionNot applicable
File size711
Date (UTC)04-Jun-2010
Time (UTC)14:52
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.0.6002.22417_none_959a42502ef381b0.manifest
File versionNot applicable
File size9,634
Date (UTC)03-Jun-2010
Time (UTC)17:40
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_df8636d0be97638181cb4a36c8c5b6aa_31bf3856ad364e35_6.0.6002.22417_none_82e567ffefb46f8c.manifest
File versionNot applicable
File size1,070
Date (UTC)04-Jun-2010
Time (UTC)14:52
PlatformNot applicable
File nameAmd64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.0.6002.22417_none_f1b8ddd3e750f2e6.manifest
File versionNot applicable
File size9,678
Date (UTC)03-Jun-2010
Time (UTC)17:53
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,295
Date (UTC)04-Jun-2010
Time (UTC)14:52
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.0.6002.22417_none_959a42502ef381b0.manifest
File versionNot applicable
File size9,634
Date (UTC)03-Jun-2010
Time (UTC)17:40
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_4e02b1697817eef86fd36b1c02116f62_31bf3856ad364e35_6.0.6002.22417_none_cae1b5c0222283ac.manifest
File versionNot applicable
File size1,068
Date (UTC)04-Jun-2010
Time (UTC)14:52
PlatformNot applicable
File nameIa64_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.0.6002.22417_none_959be6462ef18aac.manifest
File versionNot applicable
File size9,656
Date (UTC)03-Jun-2010
Time (UTC)17:19
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size2,255
Date (UTC)04-Jun-2010
Time (UTC)14:52
PlatformNot applicable
File nameX86_microsoft-windows-p..ting-spooler-client_31bf3856ad364e35_6.0.6002.22417_none_959a42502ef381b0.manifest
File versionNot applicable
File size9,634
Date (UTC)03-Jun-2010
Time (UTC)17:40
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2188792

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Article Info
Article ID : 2188792
Revision : 2
Created on : 7/19/2010
Published on : 7/19/2010
Exists online : False
Views : 307