Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Search returns results from wrong Web


View products that this article applies to.

This article was previously published under Q214835

↑ Back to the top


Symptoms

After you configure catalogs and apply them to the appropriate virtual server in the Index Server Manager, searches in the browser return results from a different Web site. Typically, this will occur on a new installation of IIS 4.0 and FrontPage 2000 with newly created catalogs. If you have other webs that the search works properly on, and these webs are using Index Server, then this article will likely not apply to your problem.

↑ Back to the top


Cause

The Cicatalog value in the idq file for the web is not being updated to point to the correct catalog. You can verify this by going to the content area of a virtual server experiencing this problem.

For example:
c:\inetpub\virtualserver
Look for a folder called _vti_script. You may have to modify your view settings in Windows Explorer to see this folder, (On the View menu, click Options, and then select the Show all files option).

Using Notepad, open the Pagename.htm0.idq file. At this point, you should be able to note that the cicatalog value is cicatalog=C:\Inetpub. The cicatalog value should point to the location of the catalog you created for this virtual server. If the cicatalog refers to C:\Inetpub, then your search bot is using the catalog for the Default Web Site. Because of this, your search will return results from the Default Web Site and not the web the search is in.

↑ Back to the top


Resolution

To resolve this problem, update the IDQ file to point to the correct catalog. You can either edit the cicatalog value to point to the correct catalog, or perform the following steps:
  1. Click Start, point to Programs, point to Windows NT 4.0 Option Pack, point to Microsoft Index Server, click Index Server Manager.
  2. Click the + next to Index Server on Local Machine.
  3. Click the Default Catalog, Web, right-click, and click Properties.
  4. Click the Web tab.
  5. Click the dropdown box for Virtual Server and click a different catalog. Before clicking OK, select the dropdown box for virtual server and reselect Default Web Site. Essentially, you are just reapplying the default catalog to the Default Web Site. This process will cause registry keys to be written so that FrontPage will be able to detect additional catalogs.
  6. With Default Web Site selected, click Ok and exit the Index Server Manager.
  7. In FrontPage, open the web for this virtual server and on the Toolsmenu click Recalculate Hyperlinks.
  8. In the browser, search for a word that would be found in this virtual server. If your problem is specific to this problem, your search should return the correct results from the correct web.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
203796� How to configure FrontPage to search a site by using Index Server

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the FrontPage 2000 Server Extensions.

↑ Back to the top


Keywords: KB214835, kbpending, kbbug

↑ Back to the top

Article Info
Article ID : 214835
Revision : 3
Created on : 2/21/2007
Published on : 2/21/2007
Exists online : False
Views : 422