Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An Exchange Server 2007 Unified Messaging user cannot play a voice mail if the caller-id of the external caller contains a wildcard character


View products that this article applies to.

Symptoms

Consider the following scenario:
  • User A is a Microsoft Exchange Server 2007 Unified Messaging user.
  • An external caller calls User A and leaves a voice mail.
  • The caller-id of the external caller contains a wildcard (*) character.
In this scenario, User A finds the following results:
  • When User A logs into Outlook Voice Access and then tries to play the voice mail, there is nothing. Or, User A receives the following error message:

    Message cannot be read.
  • User A cannot play the voice mail by using the Play on Phone feature in Microsoft Office Outlook.
  • User A cannot press the Play�button of Windows Media Player for the voice mail in Outlook and in Outlook Web Access.
Note�Certain third-party gateways add a wildcard character to the caller-id of the external caller.

↑ Back to the top


Cause

This problem occurs because the caller-id of the external caller is used for the voice mail file name. However, wildcard characters are invalid for file names.

↑ Back to the top


Resolution

To resolve this problem, install the following update rollup:
2279665� Description of Update Rollup 1 for Exchange Server 2007 Service Pack 3

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB2121947, kbsurveynew, kbhotfixrollup, kbexpertiseinter, kbfix, kbqfe

↑ Back to the top

Article Info
Article ID : 2121947
Revision : 1
Created on : 9/17/2010
Published on : 9/17/2010
Exists online : False
Views : 404