Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XL2000: Drawing Objects and AutoShapes Printed Incorrectly


View products that this article applies to.

This article was previously published under Q211490

↑ Back to the top


Symptoms

When you print a worksheet or chart in Microsoft Excel, drawing objects, AutoShapes, text boxes, and other objects may not be printed correctly. Specifically, the following symptoms may occur:
An object with a semi-transparent fill (text in cells behind the object is visible) is printed with an opaque fill.
An object with a semi-transparent fill is covered by a large black rectangle or box.
Objects, gridlines, and cell contents behind an object with an opaque fill are visible in the printed output.
Text in a text box with a colored or patterned background is not printed.
A pattern that you apply to an object is not printed correctly, or is not printed at all.
An irregularly shaped object, such as an oval or polygon, is printed as a rectangle.
An object may be printed with blurry or fuzzy edges.
These symptoms do not appear when you view the worksheet or chart in print preview.

↑ Back to the top


Cause

These problems may occur when all of the following conditions are true:
You print to a printer that uses the universal printer driver, Unidrv.dll. This includes most laser printers and inkjet printers.

NOTE: PostScript printers do not use Unidrv.dll, so they are not affected.

-and-
You are using Microsoft Windows 95.

-and-
The printer driver is configured to print in vector mode.
This behavior occurs because Microsoft Excel does not render these types of objects correctly when the printer driver is configured to print in vector mode.

NOTE: Because Windows NT supports printing only in raster mode, this problem does not occur when you print from Microsoft Excel under Windows NT 4.0.

↑ Back to the top


Resolution

To resolve this problem, change the default print mode to raster mode. To do this, follow these steps:

1.Save your work and quit any running programs.
2.On the Start menu, point to Settings, and click Printers.
3.In the list of printers, right-click the printer driver for the printer. On the shortcut menu, click Properties.
4.Click the Graphics tab.
5.Click Use Raster Graphics.
6.Click OK.

If you want to print a single document in raster mode, follow these steps:
1.Switch to the document that you want to print.
2.On the File menu, click Print. Then, click Properties.
3.Click the Graphics tab.
4.Select Use Raster Graphics.
5.Click OK. Then, click OK again to print the document.

You may also be able to prevent this problem from occurring by installing a newer version of the printer driver for your printer; however, note that this may not work in all cases.

↑ Back to the top


More information

In Windows 95, printers that use the universal printer driver, Unidrv.dll, can print in two modes: vector or raster mode. The following table describes the differences between the two modes.

   Mode     Description
   -----------------------------------------------------------------------

   Vector   High-level objects, such as polygons, are sent to the printer,
            which renders and prints them. Vector mode is faster than
            raster mode because more of the work is done by the printer.

   Raster   The computer performs all rendering work, and then sends the
            final print job to the printer to be printed. Although raster
            mode is slower than vector mode, print quality may be better
            when you use raster mode.
				
Because vector mode allows you to print documents more quickly than raster mode and provides an acceptable level of print quality, the default print mode is vector mode. However, when the printer is configured to print in vector mode, drawing objects, AutoShapes, text boxes, and other objects may not be printed correctly.

↑ Back to the top


Keywords: KB211490, kbprb

↑ Back to the top

Article Info
Article ID : 211490
Revision : 3
Created on : 10/6/2003
Published on : 10/6/2003
Exists online : False
Views : 467