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Resources in Exchange don't respond to meeting requests


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Symptoms

When you try to use Resource Booking to schedule a resource such as a conference room by using Microsoft Outlook, you may notice the following behavior when Resource Booking is unsuccessful:

  • The Resource does not automatically respond to meeting requests.
  • The Resource does not correctly respond to meeting requests.
  • The Resource is double-booking.

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Cause

An incorrect mailbox, calendar configuration, or mail flow set up can cause problems with resource mailboxes.

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Resolution

The following instructions discuss which settings to review through the Microsoft Exchange Management Shell and Outlook Web Access to determine whether a resource mailbox is configured correctly. Before you begin, have a working room available to compare settings against it.
 

The following instructions discuss which settings to review through the Microsoft Exchange Management Shell and Outlook Web Access to determine whether a resource mailbox is configured correctly. Before you begin, have a working room available to compare settings against it.

  • Check the mailbox configuration by using the following command:

    get-mailbox <Identity>| fl ResourceType,RecipientType,RecipientTypeDetails,IsLinked,LinkedMasterAccount,IsShared



    The output should resemble the following:

    ResourceType : Room
    RecipientType : UserMailbox
    RecipientTypeDetails : RoomMailbox
    IsLinked : False
    LinkedMasterAccount : NT AUTHORITY\SELF
    IsShared : False

     

  • If you have to convert the mailbox to a Room mailbox, use the following command. For more information see Convert a Mailbox.

    Set-Mailbox <Identity> -Type Room

     

  • Confirm the mailbox is configured to AutoAccept so that both the calendar attendant (which updates the calendar) and resource booking attendant (which evaluates the request against the policies) are enabled. Update if needed. For more information see Set-CalendarProcessing.

    Note If you converted the mailbox in the section above you will need to update this setting.

    Get-CalendarProcessing <Identity> | fl AutomateProcessing
    
    Set-CalendarProcessing <Identity> -AutomateProcessing AutoAccept



    After updating this setting, retry your scenario and see if the issue persists. If so continue with the next steps.

  • These are some default settings for reference. Update them to modify how users book these resources. This can be done via PowerShell or OWA (under Settings).

    AllowConflicts : False
    BookingWindowInDays : 180
    MaximumDurationInMinutes : 1440
    AllowRecurringMeetings : True
    EnforceSchedulingHorizon : True
    ScheduleOnlyDuringWorkHours : False
    ConflictPercentageAllowed : 0
    MaximumConflictInstances : 0
    ForwardRequestsToDelegates : True
    DeleteAttachments : True
    DeleteComments : True
    RemovePrivateProperty : True
    DeleteSubject : True
    AddOrganizerToSubject : True
    DeleteNonCalendarItems : True
    TentativePendingApproval : True
    EnableResponseDetails : True
    OrganizerInfo : True
    ResourceDelegates : {}
    RequestOutOfPolicy : {}
    AllRequestOutOfPolicy : False
    BookInPolicy : {}
    AllBookInPolicy : True
    RequestInPolicy : {}
    AllRequestInPolicy : False
    AddAdditionalResponse : False
    AdditionalResponse :
    RemoveOldMeetingMessages : True
    AddNewRequestsTentatively : True
    ProcessExternalMeetingMessages : False
    RemoveForwardedMeetingNotifications : False

     

  • To specifically review the policy attributes run the following:

    Get-CalendarProcessing <Identity> | fl *policy*,ResourceDelegates, ForwardRequestsToDelegates
    
    
    RequestOutOfPolicy : {}
    AllRequestOutOfPolicy : False
    BookInPolicy : {}
    AllBookInPolicy : True
    RequestInPolicy : {}
    AllRequestInPolicy : False
    ResourceDelegates : {}
    ForwardRequestsToDelegates : True

    They are explained in more detail here:

    AllRequestOutOfPolicy: By default, this is set to false to keep users from booking meetings that don’t meet the criteria for the room. If any exceptions need to be granted, users can be added as a comma-separated list to RequestOutOfPolicy and they will be able to book despite going against policy. If this setting is changed to true, anyone can book out of policy meetings.

    AllBookInPolicy: By default, this is set to true so that any user’s request to book meetings that meet the criteria for the room will be approved. If you need to lock this down to a set of users the setting can be changed to false and the authorized users can be added as a comma-separated list to BookInPolicy. The request by these users will be automatically approved.

    AllRequestInPolicy: By default, this is set to false and requsts are subject to approval by ResourceDelegates . A list of users can be added to RequestInPolicy if desired.

    ResourceDelegates: Specifies a comma-separated list of users who can approve or reject requests sent to the resource mailbox.

    ForwardRequestsToDelegates: This by default is set to true so that when requests that need to be approved are submitted they are sent to the ResourceDelegates to take action on these requests.

  • To change these settings in the Exchange Management Shell, run the following command:

    Set-CalendarProcessing <Identity> -<Property> <Value>

    An important example from the Set-CalendarProcessing TechNet article. To enable approval emails, AllBookInPolicy needs to be false.

    This example allows all users to submit in-policy requests, but the request is still subject to approval by one of the specified delegates.

    Set-CalendarProcessing -Identity "5th Floor Conference Room" -AutomateProcessing AutoAccept -AllRequestInPolicy $true -AllBookInPolicy $false -ResourceDelegates "chris@contoso.com",michelle@contoso.com

    Note For more information about conflicts see the following article.
    https://blogs.technet.microsoft.com/exchange/2011/02/07/automatic-processing-of-recurring-meeting-requests-with-conflicting-instances/

  • To change these settings in OWA, sign in to the mailbox, click the Options menu, and then click

    Resource Settings

    Note These settings can be managed by users who have full mailbox permissions to the resource mailbox. These settings are the same as most of the settings that can be modified by using Exchange Management Shell.

    Resource Scheduling Options

    Automatically process meeting requests and cancellations: Allows for automatic processing.

    Disable Reminders: No reminders are kept for meetings in the resource mailbox.

    Maximum number of days: Allows for a booking window.

    Always decline if end date is beyond this limit: Indicates whether recurring meetings are declined if the end date is beyond the booking window.

    Maximum allowed minutes: Specifies maximum length of each meeting.

    Allow scheduling only during working hours: Rejects meetings that are scheduled after work hours.

    Allow Conflicts: Multiple calendar items can be reserved during the same time.

    Allow recurring meetings: Allows for recurring meetings to be scheduled.

    Allow up to this number of individual conflicts: Specifies the maximum number of conflicts.

    Allow up to this percentage of individual conflicts: Sets a conflict percentage threshold for recurring meetings.

    Note This blog post that explains AllowConflicts and ConflictPercentageAllowed in more detail.
    https://blogs.technet.microsoft.com/exchange/2011/02/07/automatic-processing-of-recurring-meeting-requests-with-conflicting-instances/


    Resource Scheduling Permissions

    Book in Policy: All users who are defined in this option can schedule a meeting automatically.

    Request in Policy: All users who are defined in this option must wait for a manual approval even if the mailbox resource is available.

    Request out of policy: These users can automatically schedule the resource if the resource mailbox is available. If the resource is not available, the meeting that is requested must be approved manually. However, the request is never declined automatically.

    No permission: In this case, the request does not fit into any of these groups, and the request is automatically declined. Be aware that if the resource is not available, the request is declined, and the only exception is for the users of the Request out of policy setting.

    Resource Delegates: All users who are delegates of the resource mailbox and can approve or reject scheduling requests.

Corrupted Free/Busy Data

Some booking issues are related to corrupted Free/Busy data. In these cases, best practices are to update the Free/Busy information for the resource mailbox. To do this, follow these steps:

  • Load an Outlook profile for the resource mailbox in MFCMapi.
  • Locate the Free/Busy folder for the mailbox in MFCMapi that is located above Top of Information Store.
  • Delete the following two files:
  • Local Data
  • Sniffer

     

 

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Keywords: vkb1, vkb226, vkb250, kb

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Article Info
Article ID : 2005631
Revision : 11
Created on : 8/14/2018
Published on : 8/14/2018
Exists online : False
Views : 743