Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XCLN: IExpress Does Not Make Self-extracting Files


View products that this article applies to.

This article was previously published under Q189800

↑ Back to the top


Symptoms

When using Microsoft Internet Express to make a self-extracting file, you may get the following error:
Unable to find C:\Program Files\ODK\Tools\wextract.exe. Please make sure
it is in the path or in the same folder as IExpress.exe.

↑ Back to the top


Cause

The Wextract.exe file is either missing or is in the wrong folder.

↑ Back to the top


Resolution

Locate the Wextract.exe file and put it in the following folder:
C:\Program Files\ODK\Tools

↑ Back to the top


Status

Microsoft has confirmed this to be a problem in Microsoft Internet Explorer Administration Kit that ships with the Microsoft Outlook Deployment Kit.

↑ Back to the top


More information

The Wextract.exe is needed by IExpress.exe to make the cab file self- extracting. If it is not in the C:\Program Files\ODK\tools folder with Express.exe, the cab files will still be created, but the error message will appear at the end of the build process.

Locate the Wextract.exe file in the following folder:
C:\Program Files\ODK\olbin\en\optional
When the Wextract.exe file has been located, copy it to the following folder:
C:\Program Files\ODK\Tools
This will ensure that it is included in the cab files and Internet Express will build the self extracting files without error.

↑ Back to the top


Keywords: KB189800, kbpending, kbinterop, kbbug

↑ Back to the top

Article Info
Article ID : 189800
Revision : 6
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 467