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Hit Counter doesn't advance past 1 on IIS


View products that this article applies to.

This article was previously published under Q181662

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Symptoms

When you preview a page that contains a Hit Counter, the Hit Counter does not advance past the number one. This problem occurs if you host the page that contains the Hit Counter on a Microsoft Internet Information Server (IIS) for Microsoft Windows NT Server.

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Cause

This behavior occurs if the IUSR_<computername> account does not have sufficient permissions to read and write to the <Pagename>.htm.cnt file, where <computername> is the name of the Windows NT server and <Pagename> is the name of the page that contains the Hit Counter.

Note The <Pagename>.htm.cnt file stores a log of how many times the page was accessed, thus incrementing the Hit Counter.

This problem can also occur if the content has been copied or FTPd rather than published to the Web. You can recalculate hyperlinks to fix this situation.

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Resolution

Change the permissions on the <Pagename>.htm.cnt file to read and write for the IUSR_<computername> account on the Windows NT server. To do this, follow these steps:
  1. On the Windows Start menu, point to Programs, and then click Windows NT Explorer.
  2. Expand the following folder:
    C:\Inetpub\wwwroot\_private\
  3. Right-click the Default.htm.cnt file, and then click Properties on the menu that appears.
  4. Click the Security tab.
  5. Click Permissions. The IUSR_<computername> should be listed. Double-click it to edit permissions. Select the following options:
    Read (R)
    Write (W)
    NOTE: If the IUSR_<computername> account is not listed, you must add it. To do this, click Add, click the IUSR_<computername> account, and then click OK.
  6. Click OK.
Note You must verify that the correct permissions are set for each page that contains a Hit Counter. By default the <Pagename>.htm.cnt files are located in the _Private folders in each Web.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When you enable Anonymous access, the IUSR_<computername> account is used to authenticate. If the virtual directory is local to the computer, the Windows NT File System (NTFS) checks directory and file permissions. If this account does not have correct permissions on the directory, the Hit Counter does not increase. This is because Everyone has Full Control by default. Because the IUSR_<computername> is a local account, it is included in Everyone.

If the virtual directory is on a remote server, then the computer uses the "Connect As..." information to retrieve the requested pages. The FrontPage Server Extensions are implemented as CGI applications. The computer starts these applications in a separate process with the context of the user who is logged on, in this case IUSR_<computername>. Then the Hit Counter application, FPCount.exe, tries to get the _private/<Pagename>.htm.cnt file on the remote server. The request fails with the error "ACCESS DENIED" because the IUSR_<computername> account does not exist on the remote computer. The system retries until it times out. As a result, the page takes a long time to be displayed. Even if the share has assigned Everyone Full Control, the request fails because the user is unknown. When you enable the Guest account, the request does not work for the same reason.

If you disable Anonymous access and map the virtual directory to a Microsoft Site Server Membership Instance, then the computer uses the Windows NT Impersonation account. By default, this is the MemProxyUser1 account. To verify that this account exists, look in the Properties page of the Microsoft Site Server MMC Personalization and Membership Instance under Windows NT impersonation account. As with the other two accounts, this account must have access to either the local NTFS directory or be able to connect to the remote computer. To facilitate this you can configure a domain account.

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References

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
161414� How to publish a FrontPage Web to the Internet, intranet
143090� Overview of WebBot components

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Keywords: KB181662, kbfix, kbbug

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Article Info
Article ID : 181662
Revision : 2
Created on : 8/15/2006
Published on : 8/15/2006
Exists online : False
Views : 531