Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Access Denied Error When Starting Exchange Administrator


View products that this article applies to.

This article was previously published under Q170472
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

↑ Back to the top


Symptoms

When you start the Microsoft Exchange Administrator program you may receive the following error message:
Window Title: Microsoft Exchange Administrator Access denied.
Microsoft Windows NT ID no: 0xc0020005
You also receive this error when you try to run Microsoft Exchange Server Setup.

↑ Back to the top


Cause

The error occurs when the Administrator program cannot access the application event log because the data type is incorrect.

↑ Back to the top


Resolution

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

To resolve this issue verify that the entries in the registry key exist and the values are correct. If not, modify the registry key.

  1. Start Registry Editor (Regedt32.exe), and go to the following registry key:
          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog
          \Application\File:REG_EXPAND_SZ:
  2. Verify that the registry value exists. Create it if necessary.
  3. Verify that it is assigned the REG_EXPAND_SZ data type. Change the data type if needed.
  4. Verify that the string assigned is the full path to the Appevent.evt file. The default value is "%SystemRoot%\System32\Config\AppEvent.Evt" (without the quotation marks). Edit the string if necessary.
  5. Quit Registry Editor.

↑ Back to the top


Keywords: KB170472, kbprb

↑ Back to the top

Article Info
Article ID : 170472
Revision : 6
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 292