Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XCON: Unable to Start Microsoft Exchange Server MTA: Errors 1067 and 2140


View products that this article applies to.

This article was previously published under Q155027
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

If you start the Exchange Server message transfer agent (MTA), it may not start, and one of the following error messages may be displayed:
Could not start the Microsoft Exchange Message Transfer Agent service on \\<servername>
Error 1067: The process terminated unexpectedly.
Could not start the Microsoft Exchange Message Transfer Agent service on\\<servername>
Error: 2140: An internal Windows NT error has occurred.
If you use the Windows NT Event Viewer to view the application event log, the following events are logged:
Event ID: 137, Source: MSExchangeMTA.
A fatal directory error occurred. Change to the maximum logging level for more details. [MTA MAIN BASE 1 15] (16)
After you change the logging to Maximum (open the properties of the MTA object, and in the Diagnostics Logging page, click Directory Access and Field Engineering), the MTA logs one of the following error messages in the Event Viewer:
Event Id: 2245, Type: Warning, Category: Directory Access Directory operation (ds_read) failed with problem DS_E_NO_SUCH_OBJECT. Attribute . Directory Name (string): /O=<organization> /OU=<site>/CN=CONFIGURATION/CN=SERVERS/CN=<server name>/CN=MICROSOFT MTA. [RD Server MAIN BASE 1 114] (8)
Event 2241: Directory operation (ds_search) failed with problem DS_E_NO_SUCH_OBJECT. Attribute: . Root Directory Name: / o=<organization>/ou=<site>/cn=Configuration/cn=Connections. [RD Server MAIN BASE 1 116] (12)

↑ Back to the top


Cause

The value of the following registry key in the HKEY_LOCAL_MACHINE subtree does not match the corresponding directory entry:
System\CurrentControlSet\Services\MSExchangeMTA\Parameters\X500 DN
The wrong Organization or Site name was used when Exchange Server was reinstalled on the server.

↑ Back to the top


Resolution

Check the value of the registry key and edit it, if necessary, so that it matches the corresponding directory entry, or reinstall Exchange Server using the correct Organization and Site names.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Start Registry Editor (Regedt32.exe).
  2. Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:
    System\CurrentControlSet\Services\MSExchangeMTA\Parameters\X500 DN
  3. Check the value for this key. The Organization [o=], Site [ou=], and Server Directory names [cn=] must exactly match the properties of the Organization, Site, and Server objects as they are displayed in the Exchange Server Administrator program.

    To see whether these objects match the value of the registry key:
    1. In the left pane of the Exchange Server Administrator program, click to expand the Organization object, click to expand the Site object, and then click to expand the Server object.
    2. On the File menu, click Properties. The Directory Name of each of these objects must exactly match the corresponding attributes in the registry setting described in step 3.

↑ Back to the top


More information

When the Exchange Server MTA starts, it checks the Distinguished Name (DN) of the MTA object in the registry and verifies that it is exactly the same as the one that is stored in the Exchange Server directory.

↑ Back to the top


Keywords: KB155027, kbusage, kbprb

↑ Back to the top

Article Info
Article ID : 155027
Revision : 6
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 407