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OL: Folder Contacts List Contains No Entries When You View the Properties of a Mail-Enabled Public Folder


View products that this article applies to.

Symptoms

When you click a mail-enabled public folder from the Global Address List from within Microsoft Outlook, and then you click Properties, the Folder contacts list does not contain any entries even though you have granted Folder contact client permissions to other recipients. You expect the Folder contacts list to contain the contacts like it does when you connect to an Exchange Server 5.5 computer.

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Cause

This problem occurs because Exchange 2000 does not currently populate the Folder contacts list when you view the properties of a mail-enabled public folder from the Global Address List.

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Workaround

To work around this problem, use one of the following methods.

Method 1: View the Permissions of the Public Folder

Determine the folder contacts using the Permissions tab in the Folder Name Properties dialog box, where Folder Name is the name of the public folder. To do so, follow these steps:
  1. Start Outlook, and then locate and right-click the public folder in the Folder List.
  2. Click Properties, and then click the Permissions tab.
  3. In the Name list, click an account, and then under Permissions, view the Folder contact check box to determine if it is selected.

    The check boxes may not be available (or appear dimmed), but they still reflect the different permission levels for each user account that is selected.

Method 2: Manually Populate the Folder Contacts List

Manually populate the Folder contacts list by using the ADSI Edit utility to edit the pFContacts attribute. To do so, follow these steps.

Note This method works in some cases, but the same steps do not work in other cases.

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Exchange 2000 Server, or both. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Determine the folder contacts that you want to add to the pFContacts attribute. To determine which recipients have been granted Folder contact permissions, follow these steps:
    1. Start the Exchange System Manager snap-in, and then locate the public folder whose properties you want to view.
    2. Right-click the public folder, and then click Properties.
    3. Click the Permissions tab, and then click Client permissions.
    4. In the Name list, click a user, and then note if the Folder contact check box is selected.
  2. Start the ADSI Edit utility.

    Note ADSI Edit is located in Microsoft Windows 2000 Support Tools. To install the Windows 2000 Support Tools, run Setup in the Support\Tools folder on the Windows 2000 Server CD-ROM. For additional information about the Windows 2000 Support Tools, see the Readme.doc file in the Support\Tools folder on the Windows 2000 Server CD-ROM.
  3. Expand Domain NC [server.example.com] (where server.example.com is the fully qualified domain name (FQDN) of your Exchange 2000 computer), expand DC=example,DC=com, and then click Microsoft Exchange System Objects.
  4. In the right pane of the ADSI Edit snap-in, double-click CN=foldername, where foldername is the name of the public folder whose attributes you want to edit.
  5. In the Select which properties to view list, click Both.
  6. In the Select a property to view list, click pFContacts.
  7. In the Edit Attribute box, type the name of a folder contact in the distinguished name format, and then click Add.

    Note There are no spaces after the commas in the distinguished name.
  8. To determine the distinguished name of a recipient or folder contact, follow these steps:
    1. Click the ADSI Edit window to return focus to it.

      Note You do not have to close the CN=foldername-Folder Properties dialog box.
    2. In the left pane, click CN=Users, where Users is the container where the user account is stored.
    3. In the right pane, in the Name list, locate CN=User Name, where User Name is the name of the user whose distinguished name you want to determine.
    4. Note the entry in the Distinguished Name list that corresponds to the user who you located. For example, CN=User Name,CN=Users,DC=example,DC=com.
  9. When you finish adding folder contacts to the pFContacts attribute, click OK, and then quit the ADSI Edit snap-in.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: KB812349, kbprb, kbbug, kbnofix

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Article Info
Article ID : 812349
Revision : 6
Created on : 2/28/2007
Published on : 2/28/2007
Exists online : False
Views : 334