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You receive a "The file may have been changed" error message when you save a workbook to a network server in Excel 2002 or in Excel 2003


View products that this article applies to.

Symptoms

When you try to save a Microsoft Excel workbook to a network server, you may receive the following message if the server is running an intermediate service, such as Services for Macintosh, or there is latency in the network connection during the book open:
The file (filename.xls) may have been changed by another user since you last saved it. In that case, what do you want to do?
  • Save a copy
  • Overwrite changes
Save a copy is the default choice.

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Cause

This message is a new feature in Microsoft Excel 2002 that protects you from overwriting someone else's changes if you lose network connectivity.

If you open a file from a network drive and then your computer loses network connectivity, a second person can open the same file, make changes, save, and then close the file without your knowledge.

If you then try to save the file, Excel compares the time stamp of the file in memory with the time stamp of the file on the network drive. If the time stamp does not match, Excel prompts you with the message described earlier.

There are two conditions when a user may receive this prompt incorrectly:
  • When you save the file on a network server that is running an intermediate service, the computer may write additional information to the file after Excel obtains the time stamp. For example, computers running Services for Macintosh will write additional Macintosh-related information to each file. This can occur after the time stamp is obtained by Excel.
  • For files opened with write access, Excel will write owner information to the file and induce a change in the last modified time stamp. Excel will collect the time stamp information after this write operation is completed successfully, and the rest of the workbook is read in. However, if there is latency in the network, it is possible the file will not be completely updated from the local file cache when Excel asks for the time stamp. Therefore, the server may return the time value as set before the last edit, and will not match what Excel expects when it checks the time on save. This can occur more frequently if the file is located on Network Appliance (NetAPP) storage device or across a Wide Area Network (WAN).
When you try save the file, Excel detects the difference in time stamps between open and save, and prompts you accordingly.

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Resolution

Note Do not deploy the following registry key unless you are sure of the root cause of the warning message. If you deploy this registry key without knowing what is causing the warning message to appear, you could potentially mask a larger network or server issue.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

Excel 2003

To resolve this issue in Excel 2003, follow these steps:
  1. Click Start, click Run, type regedit, and then press ENTER.
  2. Locate and then click the following key:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\11.0\Excel\Options
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type QFE_Saskatchewan for the name, and then press ENTER.
  5. Right-click the
    QFE_Saskatchewan
    entry, and then click Modify.
  6. In the Value box, type 2. When you type this value, Excel will always flush the file cache before the program obtains the time stamp. (This should resolve the problem most of the time.) Or, type 1 to have Excel disable the time stamp check and suppress the dialog in every case.

    Note We do not recommend disabling the time stamp check.
  7. Click OK to save the setting.

Excel 2002

This problem was first fixed in a hotfix that is now contained in a Service Pack. If you have installed the latest Office XP Service Pack, you do not have to install the hotfix.

Service Pack Information

This problem is corrected in Office XP Service Pack 3.
To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP service pack

To enable the fix

To enable this design change, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then press ENTER.
  2. Locate and then click the following key:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\10.0\Excel\Options
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type QFE_Saskatchewan for the name, and then press ENTER.
  5. Right-click the
    QFE_Saskatchewan
    entry, and then click Modify.
  6. In the Value box, type 2 to have Excel always flush the file cache before obtaining the time stamp. This should resolve the problem most of the time. Or, type 1 to have Excel disable the time stamp check and suppress the dialog in every case.

    Note We do not recommend disabling the time stamp check.
  7. Click OK to save the setting.
  8. Re-start Excel to have the setting take effect for that user.

Hotfix Information

How to obtain the hotfix

This issue is fixed in the Excel 2002 Post-Service Pack 2 hotfix package that is dated June 7, 2003.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
822347 Description of Excel 2002 post-Service Pack 2 hotfix package: June 7, 2003

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Workaround

To work around this problem, use one of the following methods:
  • Share your Excel workbooks by clicking Share workbook on the Tools menu. You can restrict access to the file by using the share permissions. Shared workbooks keep track of multi-user edits and do not require the time stamp check.
  • Save your files to a Microsoft Windows 2000 or Microsoft Windows Server 2003 on a Local Area Network (LAN), and disable services that can modify the file unexpectedly, such as the Services for Macintosh.
  • If you are sure that you are the only person who has access to the file or you are the only person who is using the file, just click Overwrite changes in the dialog box.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Office XP Service Pack 3.

Note To enable the hotfix, you must add the registry key that is documented in the "Resolution" section after Office XP Service Pack 3 is installed.

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Keywords: KB324491, kbnofix, kberrmsg, kbbug, kbhotfixserver, kbqfe

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Article Info
Article ID : 324491
Revision : 16
Created on : 2/1/2007
Published on : 2/1/2007
Exists online : False
Views : 522