Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Resource Booking Assistant crashes after you upgrade to Exchange Server 2013 Cumulative Update 5


View products that this article applies to.

Symptoms

After you upgrade to Cumulative Update 5 for Microsoft Exchange Server 2013, the Resource Booking Assistant (RBA) crashes at two gigabytes (GB), and it cannot process on the resource room to accept the message on the mailbox.

↑ Back to the top


Cause

This issue occurs because too many instances of the Calendar Repair Assistant (CRA) are running on the server. This causes RBA to hit the memory limit and therefore crashes.

↑ Back to the top


Resolution

To resolve this issue, install Cumulative Update 7 for Exchange Server 2013.

↑ Back to the top


Workaround

To work around this issue, follow the instructions to limit the number of concurrent CRA threads to no more than five: 
  • Under the Exchange installation path \Bin folder, open the MSExchangeMailboxAssistants.exe.config file.
  • Add the following key under the appsettings node:
    <add key="Workload.CalendarRepairAssistant.MaxConcurrency" value="5"/>
  • Restart the Microsoft Exchange Mailbox Assistants service (MSExchangeMailboxAssistants).

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 2993871
Revision : 1
Created on : 1/7/2017
Published on : 12/9/2014
Exists online : False
Views : 329