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USB HID keyboard may incorrectly report the previous auto-repeat scan code in Windows Vista or in Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Windows Vista or Windows Server 2008 on a multiprocessor computer.
  • You use a USB human interface device (HID) keyboard on the computer.
  • You press different keys on the keyboard.
In this scenario, the USB HID keyboard may incorrectly report the previous auto-repeat scan code.

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Cause

This issue occurs because of a race condition in the HID keyboard filter driver (Kbdhid.sys).

When the race condition occurs, the driver does not stop the previous auto-repeat routine timer if the keyboard reports a new scan code. Therefore, you encounter the issue that is described in the "Symptoms" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
I8042prt.sys6.0.6001.2286454,78428-Feb-201113:07x86
Kbd106.dll6.0.6001.228646,65628-Feb-201114:39x86
Kbdclass.sys6.0.6001.2286432,14401-Mar-201109:13x86
Kbdhid.sys6.0.6001.2286417,92028-Feb-201113:07x86
I8042prt.sys6.0.6002.2259854,78428-Feb-201115:49x86
Kbd106.dll6.0.6002.225986,65628-Feb-201118:18x86
Kbdclass.sys6.0.6002.2259832,12828-Feb-201118:48x86
Kbdhid.sys6.0.6002.2259817,92028-Feb-201115:49x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
I8042prt.sys6.0.6001.2286464,00028-Feb-201113:31x64
Kbd106.dll6.0.6001.228648,19228-Feb-201114:55x64
Kbdclass.sys6.0.6001.2286438,80001-Mar-201109:15x64
Kbdhid.sys6.0.6001.2286422,52828-Feb-201113:31x64
I8042prt.sys6.0.6002.2259864,00028-Feb-201114:09x64
Kbd106.dll6.0.6002.225988,19228-Feb-201115:59x64
Kbdclass.sys6.0.6002.2259838,78428-Feb-201116:28x64
Kbdhid.sys6.0.6002.2259822,52828-Feb-201114:09x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size3,577
Date (UTC)01-Mar-2011
Time (UTC)09:24
PlatformNot applicable
File nameX86_keyboard.inf_31bf3856ad364e35_6.0.6001.22864_none_979b398df243855b.manifest
File versionNot applicable
File size3,417
Date (UTC)01-Mar-2011
Time (UTC)09:25
PlatformNot applicable
File nameX86_keyboard.inf_31bf3856ad364e35_6.0.6002.22598_none_99653cd9ef7e93ae.manifest
File versionNot applicable
File size3,417
Date (UTC)01-Mar-2011
Time (UTC)09:25
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_keyboard.inf_31bf3856ad364e35_6.0.6001.22864_none_f3b9d511aaa0f691.manifest
File versionNot applicable
File size3,419
Date (UTC)01-Mar-2011
Time (UTC)09:24
PlatformNot applicable
File nameAmd64_keyboard.inf_31bf3856ad364e35_6.0.6002.22598_none_f583d85da7dc04e4.manifest
File versionNot applicable
File size3,419
Date (UTC)01-Mar-2011
Time (UTC)09:24
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,605
Date (UTC)01-Mar-2011
Time (UTC)09:24
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseinter, KB2497148

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Article Info
Article ID : 2497148
Revision : 1
Created on : 4/18/2011
Published on : 4/18/2011
Exists online : False
Views : 370