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Calendar items that are copied are missing in Exchange Server 2007


View products that this article applies to.

Symptoms

Consider the following scenarios.

Scenario 1
  • You use a third-party mobile device to connect to a mailbox that is hosted on Microsoft Exchange Server 2007 or on an Exchange Server 2007 shared calendar.
  • You copy a calendar item to a different time or day.
  • The calendar item contains an attachment.
Scenario 2
  • You use a third-party mobile device to connect to a mailbox that is hosted on Exchange Server 2007 or on an Exchange Server 2007 shared calendar.
  • You copy a calendar item to a different time or day.
  • You copy the calendar item to a different time or day again.
Scenario 3
  • You use a third-party mobile device to connect to a mailbox that is hosted on Exchange Server 2007 or on an Exchange Server 2007 shared calendar.
  • You create a recurring calendar item.
  • You change an occurrence in the recurring series.
In these scenarios, calendar items may disappear unexpectedly.

Additionally, you may experience one or more of the following symptoms in Microsoft Office Outlook when this issue occurs:
  • If the calendar items are meetings that include attendees, the meeting organizer may receive attendee responses that are out of order.
  • If the calendar items are meetings that include attendees, the attendees may receive meeting updates that are out of order.
  • Some requests from the meeting organizer are moved to the Deleted Items folder on the attendee's computer. Additionally, these items are marked as Out of date.
  • New meetings that are scheduled incorrectly change previously scheduled meetings.

    Note This change can delete the previously scheduled meeting from the calendar.

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Cause

This issue can occur if the GlobalObjectID (GOID) property for an item is duplicated when you copy the calendar item.

Notes
  • Some mobile device manufacturers use the GOID property to uniquely identify items.
  • Some devices will reject the meeting that is duplicated as an invalid item.

Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around this issue, do not copy a calendar item to create the new calendar items. Instead, manually re-create the calendar item in Office Outlook, in Microsoft Office Outlook Web App, or on the mobile device.

Notes
  • After you re-create a calendar item in Office Outlook, in Office Outlook Web App, or on a mobile device, you can copy the calendar item that you recreated.
  • If your calendar items contains an attachment, you must manually delete the calendar items that you created by using the copy process.

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More information

You can use the most recent version of the Calendar Checking Tool for Outlook (CalCheck) utility to check your Outlook calendar for potential problems. The following sample output from the CalCheck utility shows items with duplicate GOID values:
05/16/2012 12:45:18AM ERROR: PidLidGlobalObjectId and PidLidCleanGlobalObjectId values match on two items.
05/16/2012 12:45:18AM This Item Subject: Dupe GOID test demo 2nd copy

Start Time: 05/22/2012 07:00:00PM
End Time: 05/22/2012 07:30:00PM
Other Item Subject: Dupe GOID test demo 1st copy
Start Time: 05/22/2012 06:00:00PM
End Time: 05/22/2012 06:30:00PM 

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References

For more information about the CalCheck utility, see the following article in the Microsoft Knowledge Base:
2678030 Information about the Calendar Checking Tool for Outlook (CalCheck)
For information about how to download the CalCheck utility, visit the following Microsoft website:

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Keywords: KB2714118, kbprb, kbtshoot, kbsurveynew

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Article Info
Article ID : 2714118
Revision : 2
Created on : 10/4/2012
Published on : 10/4/2012
Exists online : False
Views : 1533