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"0x000000BE" Stop error message when you use the Storport.sys driver to manage some storage devices in Windows Server 2008, in Windows Vista, in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install some high-performance storage devices on a computer that is running Windows Server 2008, Windows Vista, Windows 7 or Windows Server 2008 R2. For example, you install a host-based RAID or a fiber-channel adapter.
  • The Storport.sys driver is used to manage these storage devices.
In this scenario, the computer may restart unexpectedly, and you may receive one of the following Stop error messages:
STOP 0x000000BE (parameter1, parameter2, parameter3, parameter4) ATTEMPTED_WRITE_TO_READONLY_MEMORY

STOP 0x000000D1 (parameter1, parameter2, parameter3, parameter4) DRIVER_IRQL_NOT_LESS_OR_EQUAL
Note
  • The parameters in this error message vary, depending on the configuration of the computer.
  • Not all "0x000000BE" or "0x000000D1" Stop errors are caused by this issue.
  • If the storage devices are paused and then resumed frequently, this issue usually occurs.

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Cause

This issue occurs because a signed value is used as the index of the debug log list in the Storport.sys driver. When the value exceeds the maximum positive value, a negative index is used to query debug log entries. This behavior causes some invalid memory to be accessed. Therefore, the Stop code is triggered.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 SP2
  • Windows 7
  • Windows Server 2008 R2
For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    0.
    20xxx
    Windows VistaRTMLDR
    6.0.600
    1.
    22xxx
    Windows Vista and Windows Server 2008SP1LDR
    6.0.600
    2.
    22xxx
    Windows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22689123,78411-May-201016:25x86
Storport.sys6.0.6002.22402123,27211-May-201017:38x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22689159,62411-May-201016:53x64
Storport.sys6.0.6002.22402166,28011-May-201017:49x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.0.6001.22689372,11211-May-201016:29IA-64
Storport.sys6.0.6002.22402372,10411-May-201017:32IA-64
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.1.760
    0.
    20xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.1.7600.20913148,86402-Mar-201106:45x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.1.7600.20913187,77602-Mar-201107:19x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Storport.sys6.1.7600.20913428,41602-Mar-201106:07IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot applicable
File size3,565
Date (UTC)12-May-2010
Time (UTC)00:33
PlatformNot applicable
File nameX86_microsoft-windows-storport_31bf3856ad364e35_6.0.6001.22689_none_27b8782c49853af7.manifest
File versionNot applicable
File size5,145
Date (UTC)11-May-2010
Time (UTC)17:31
PlatformNot applicable
File nameX86_microsoft-windows-storport_31bf3856ad364e35_6.0.6002.22402_none_29ee69544670fc59.manifest
File versionNot applicable
File size5,145
Date (UTC)11-May-2010
Time (UTC)18:43
PlatformNot applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_microsoft-windows-storport_31bf3856ad364e35_6.0.6001.22689_none_83d713b001e2ac2d.manifest
File versionNot applicable
File size5,397
Date (UTC)11-May-2010
Time (UTC)18:01
PlatformNot applicable
File nameAmd64_microsoft-windows-storport_31bf3856ad364e35_6.0.6002.22402_none_860d04d7fece6d8f.manifest
File versionNot applicable
File size5,397
Date (UTC)11-May-2010
Time (UTC)18:50
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_microsoft-windows-storport_31bf3856ad364e35_6.0.6001.22689_none_27ba1c22498343f3.manifest
File versionNot Applicable
File size5,395
Date (UTC)11-May-2010
Time (UTC)17:16
PlatformNot Applicable
File nameIa64_microsoft-windows-storport_31bf3856ad364e35_6.0.6002.22402_none_29f00d4a466f0555.manifest
File versionNot Applicable
File size5,395
Date (UTC)11-May-2010
Time (UTC)18:18
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,748
Date (UTC)12-May-2010
Time (UTC)00:33
PlatformNot Applicable

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size1,874
Date (UTC)02-Mar-2011
Time (UTC)09:35
PlatformNot Applicable
File nameX86_microsoft-windows-storport_31bf3856ad364e35_6.1.7600.20913_none_2825f9f5aa69168c.manifest
File versionNot Applicable
File size15,725
Date (UTC)02-Mar-2011
Time (UTC)07:10
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_microsoft-windows-storport_31bf3856ad364e35_6.1.7600.20913_none_8444957962c687c2.manifest
File versionNot Applicable
File size15,727
Date (UTC)02-Mar-2011
Time (UTC)08:06
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,108
Date (UTC)02-Mar-2011
Time (UTC)09:35
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-storport_31bf3856ad364e35_6.1.7600.20913_none_28279debaa671f88.manifest
File versionNot Applicable
File size15,726
Date (UTC)02-Mar-2011
Time (UTC)08:07
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,684
Date (UTC)02-Mar-2011
Time (UTC)09:35
PlatformNot Applicable

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Keywords: kb, kbmdd, kbhotfixserver, kbautohotfix, kbsurveynew, kbexpertiseadvanced, kbqfe, kbfix

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Article Info
Article ID : 983554
Revision : 1
Created on : 1/7/2017
Published on : 10/6/2014
Exists online : False
Views : 303