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The "Previous Versions" list of a DFS share is empty if you access the share from a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a Distributed File System (DFS) share on a file server that is running a Windows Server operating system.
  • You run the Volume Shadow Copy Service (VSS) on the file server.
  • You enable the Downlevel Timewarp feature on the file server so that�client computers�that are running an earlier version of Windows can see the Previous Versions list of the DFS share.

    To do this, you set the following registry key on the file server:
    Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters
    Name: DisableDownLevelTimewarp
    Type: DWORD
    Value: 00000000
    
    Note The Downlevel Timewarp feature was developed to support a client computer that is running Windows 2000 or Windows XP.
  • You access this DFS share from a computer that is running Windows Vista or Windows Server 2008. Then, you try to view the Previous Versions�list�of the DFS share.
In this scenario, the Previous Versions�list is empty. Therefore, you cannot see earlier versions of the share, and you cannot restore the share to an earlier version.�

However, you can see a correct list of earlier versions when you access the DFS share from a client that is running an earlier version of Windows Server.

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Cause

This issue occurs because of an error in the Shell32.dll file.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2). For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600 0 . 20xxxWindows VistaRTMLDR
    6.0.600 1 . 22xxxWindows Vista and Windows Server 2008SP1LDR
    6.0.600 2 . 22xxxWindows Vista and Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.0.6002.2239811,586,56004-May-201019:37x86
For all supported x64-based versions of Windows Server 2008 and of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.0.6002.2239812,900,86404-May-201019:42x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Shell32.dll6.0.6002.2239819,088,89604-May-201019:25IA-64

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Workaround

To work around this issue, change the value of the DisableDownLevelTimewarp registry entry to 00000001.



The registry entry can be found at the following location:
Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters
Name: DisableDownLevelTimewarp
Type: DWORD
Value: 00000001
Notes
  • When you change the value of this registry entry, downlevel client computers cannot obtain the Previous Versions list of the DFS share.
  • This registry change does not require a server restart.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to set up a DFS share, visit the following Microsoft website: For more information about the VSS, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Vista and of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size3,068
Date (UTC)05-May-2010
Time (UTC)10:11
PlatformNot Applicable
File nameX86_5a394809a23429f0ffd2dac5524f6028_31bf3856ad364e35_6.0.6002.22398_none_4e2b68a6a32935a9.manifest
File versionNot Applicable
File size695
Date (UTC)05-May-2010
Time (UTC)10:11
PlatformNot Applicable
File nameX86_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22398_none_6e3ff61328819aa1.manifest
File versionNot Applicable
File size904,280
Date (UTC)05-May-2010
Time (UTC)05:43
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Vista and of Windows Server 2008
File nameAmd64_d5ec7644be87084285f880c2eea66cec_31bf3856ad364e35_6.0.6002.22398_none_d1e6ad4e842c58d5.manifest
File versionNot Applicable
File size1,040
Date (UTC)05-May-2010
Time (UTC)10:12
PlatformNot Applicable
File nameAmd64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22398_none_ca5e9196e0df0bd7.manifest
File versionNot Applicable
File size906,212
Date (UTC)05-May-2010
Time (UTC)06:18
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size3,092
Date (UTC)05-May-2010
Time (UTC)10:12
PlatformNot Applicable
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22398_none_d4b33be9153fcdd2.manifest
File versionNot Applicable
File size899,183
Date (UTC)05-May-2010
Time (UTC)05:38
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_155e9719174e36022b0cad12ddfb1909_31bf3856ad364e35_6.0.6002.22398_none_d8c88b65d8d66987.manifest
File versionNot Applicable
File size1,038
Date (UTC)05-May-2010
Time (UTC)10:11
PlatformNot Applicable
File nameIa64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22398_none_6e419a09287fa39d.manifest
File versionNot Applicable
File size906,144
Date (UTC)05-May-2010
Time (UTC)06:31
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,247
Date (UTC)05-May-2010
Time (UTC)10:11
PlatformNot Applicable
File nameWow64_microsoft-windows-shell32_31bf3856ad364e35_6.0.6002.22398_none_d4b33be9153fcdd2.manifest
File versionNot Applicable
File size899,183
Date (UTC)05-May-2010
Time (UTC)05:38
PlatformNot Applicable

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Keywords: kbprb, kbsurveynew, kbexpertiseadvanced, kbhotfixserver, kbautohotfix, kbqfe, kbfix, KB983437

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Article Info
Article ID : 983437
Revision : 3
Created on : 7/21/2010
Published on : 7/21/2010
Exists online : False
Views : 264