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The Visual Studio development environment crashes when you open Visual Studio 2005, Visual Studio 2008, or Visual Studio 2010


View products that this article applies to.

Symptoms

You try to open Microsoft Visual Studio 2005, Microsoft Visual Studio 2008, or Microsoft Visual Studio 2010. However, the Visual Studio development environment crashes.

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Cause

This issue occurs when the system registry contains incorrect information for the IServiceProvider interface. An application installer may have registered this interface to an incorrect proxy/stub dynamic link library.

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Resolution

To resolve this problem, enter correct information into the registry by registering the Ieproxy.dll manually. To do this, follow these steps:
  1. Click
    StartStart button
    , type
    cmd
    in the search box.
  2. In the results list, right-click
    cmd
    , and then click
    Run as administrator
    to start an elevated command prompt.


    If you are prompted for an administrator password, type your password.If you are prompted for confirmation, click
    Continue
    .
  3. For 32-bit operating systems, run the following command:
    regsvr32 "c:\Program Files\Internet Explorer\ieproxy.dll"
    For 64-bit operating systems, run the following command:
    regsvr32 "c:\Program Files (x86)\Internet Explorer\ieproxy.dll"


Note This issue was first reported for an operating system that is based on Windows 7. The resolution was tested fully on this operating system. If you are running other operating systems, this resolution may not work. Specifically, if Windows Internet Explorer 8 is not installed on the computer, the proxy/stub dynamic link library for the IServiceProvider interface will be Actxprxy.dll instead of Leproxy.dll.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
This issue is known to occur when you install the AMD CodeAnalyst Performance Analyzer version 2.94 or earlier versions. Specifically, this issue occurs when you try to integrate the AMD CodeAnalyst Performance Analyzer with Visual Studio during the installation.

In this situation, we recommend that you follow the steps that are described in the "Resolution" section. Then, install the latest version of the AMD CodeAnalyst Performance Analyzer that integrates correctly with Visual Studio.

Note Other third-party installers may also be associated with this issue.

For more information about the AMD CodeAnalyst Performance Analyzer, visit the following Web site:

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Keywords: kbtshoot, kbexpertiseadvanced, kbsurveynew, kbprb, kb

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Article Info
Article ID : 983279
Revision : 1
Created on : 1/7/2017
Published on : 6/21/2014
Exists online : False
Views : 367