Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A SQL Server Agent resource cannot be brought online in a Windows Server 2008-based failover cluster


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a node of a Windows Server 2008-based failover cluster, you install SQL Server 2008 with the "per-service SID" option.
  • You enable Kerberos authentication on the SQL server.
  • You set a SQL Server account and a SQL Server Agent account by using different domain user accounts.
In this scenario, the SQL Server Agent resource cannot be brought online. Additionally, the following events are logged in the Application log:

↑ Back to the top


Cause

This issue occurs because the Cluster service does not register the fully qualified domain names (FQDN) of a resource name to the Local Security Authority (LSA).

The Cluster service registers the FQDN of a resource name to LSA and to the DNS database at the same time. However, the DNS registration occurs one time every 24 hours. Therefore, there is a delay in the registration of the FQDN to LSA.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6002.22401919,04010-May-201016:53x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6002.224011,155,07210-May-201016:55x64
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Clusres.dll6.0.6002.224011,925,63210-May-201016:47IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Vista and for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008
File nameUpdate.mum
File versionNot Applicable
File size2,224
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable
File nameX86_25117a9ac770cc8e037806eb6dce6159_31bf3856ad364e35_6.0.6002.22401_none_4dd9ed6d8ce0c607.manifest
File versionNot Applicable
File size711
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable
File nameX86_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6002.22401_none_c34bb98cb33e4637.manifest
File versionNot Applicable
File size10,641
Date (UTC)10-May-2010
Time (UTC)18:38
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_9865deabe33f175b7397b28df433c13f_31bf3856ad364e35_6.0.6002.22401_none_1001171e77f6dd33.manifest
File versionNot Applicable
File size715
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable
File nameAmd64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6002.22401_none_1f6a55106b9bb76d.manifest
File versionNot Applicable
File size10,693
Date (UTC)10-May-2010
Time (UTC)18:38
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,240
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_2e3559a55f65581234b49869a4b072f1_31bf3856ad364e35_6.0.6002.22401_none_a17e341562a168a1.manifest
File versionNot Applicable
File size713
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable
File nameIa64_microsoft-windows-f..overcluster-clusres_31bf3856ad364e35_6.0.6002.22401_none_c34d5d82b33c4f33.manifest
File versionNot Applicable
File size10,667
Date (UTC)10-May-2010
Time (UTC)18:15
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,581
Date (UTC)11-May-2010
Time (UTC)00:12
PlatformNot Applicable

↑ Back to the top


Keywords: kbfix, kbqfe, kbexpertiseadvanced, kbclustering, kbautohotfix, kbhotfixserver, kb, kbsurveynew

↑ Back to the top

Article Info
Article ID : 983229
Revision : 3
Created on : 9/28/2018
Published on : 9/28/2018
Exists online : False
Views : 126