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The .xls file as an attachment is empty when you access an Exchange Server 2010 mailbox by using OWA


View products that this article applies to.

Symptoms

You access a Microsoft Exchange Server 2010 mailbox by using Outlook Web App (OWA). In this scenario, when you download an .xls file attachment and then try to open the file, the file is empty. Currently, Exchange Server 2010 RTM cannot bypass XML Filtering for OWA attachments. XML attachments cannot be saved from messages when you use OWA. 

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Cause

This problem occurs if the .xls file contains XML data. If a file that contains XML data is attached to an email message, the XML content in the file is removed when you open or save the attachment by using OWA.

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Resolution

To resolve this problem, install the following update rollup:
982639 Description of Update Rollup 4 for Exchange Server 2010

After you apply this hotfix, a new option named "BypassOwaXmlAttachmentFiltering" is provided. An Exchange administrator may use the BypassOwaXmlAttachmentFiltering option to configure the Exchange Server behavior on this area.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

The BypassOwaXmlAttachmentFiltering option is in the appSettings section in the Web.Config file:
<appSettings>
..
<add key = "BypassOwaXmlAttachmentFiltering" value="true" />
..
</appSettings>
The Web.Config file is in the following location:

<drive>\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa

The BypassOwaXmlAttachmentFiltering option lets you disable XML sniffing for attachments.


Note If the value of the BypassOwaXmlAttachmentFiltering option is set to True, you may see the XML context on the attachment.

Important You have to set the .xls file name extension in the Force Save list in the Direct File Access Setting page in the Exchange Management Console to take this hotfix to effect. To set a file type in the Force Save list, follow these steps:
  1. In the Exchange Management Console, click Server Configuration, and then click Client Access.
  2. In the action pane, under the Outlook Web Access tab, click Properties.
  3. Either click the Public Computer File Access tab or click the Private Computer File Access tab.
  4. Under Direct file access, select the Enable direct file access check box to let users download attachments.
  5. Click Customize.
  6. On the Direct File Access Settings page, click Force Save. Then, set the .xls file name extensions in the Enter the file extensions you want to force save, one at a time dialog box on the Force Save List page, and then click Add.
  7. Click OK three times to save your settings.
For more information about how to configure public computer file access or private computer file access, visit the following Microsoft website:

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Keywords: kbsurveynew, kbexpertiseinter, kbqfe, kbhotfixrollup, kbfix, kb

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Article Info
Article ID : 983200
Revision : 3
Created on : 9/25/2018
Published on : 9/25/2018
Exists online : False
Views : 363