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"WBEM_E_FAILED" error when you use the "Microsoft_IPMI" WMI class in Windows Server 2003 SP2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2003 Service Pack 2 (SP2). This computer supports the Intelligent Platform Management Interface (IPMI) standard.
  • You call the RequestResponse method of the Microsoft_IPMI Windows Management Instrumentation (WMI) class to query data from an Intelligent Platform Management Interface (IPMI) provider.
In this scenario, the WMI query fails, and you receive the following error:
WBEM_E_FAILED

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Cause

This�issue occurs because of a hard-coded limitation�of 64 bytes for a buffer in the Ipmidrv.sys driver. If the length of the returned data is larger than 64 bytes, the RequestResponse method fails together with the "WBEM_E_FAILED" error.

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Resolution

Note After you install this hotfix, the buffer limitation is changed to 256 bytes.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information note
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.sys5.2.3790.470057,34428-Apr-201014:51x86
For all supported x64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.sys5.2.3790.470086,01629-Apr-201003:15x64
For all supported IA-64-based versions of Windows Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.sys5.2.3790.4700136,70429-Apr-201003:15IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the Microsoft_IPMI class, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseinter, kbhotfixserver, kbqfe, kbfix, kbautohotfix, kbsurveynew, kbprb, KB982915

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Article Info
Article ID : 982915
Revision : 2
Created on : 6/10/2010
Published on : 6/10/2010
Exists online : False
Views : 343