Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Windows cannot connect to printer" error message when you try to create a Point and Print connection to a remote printer from a Windows 7 or Windows Server 2008 R2-based client computer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a client computer that is running Windows 7 or Windows Server 2008 R2.
  • You try to create a Point and Print connection to a remote printer from the client computer.
In this scenario, the operation fails and you receive the following error message:

=================
Title: Add Printer
Text: Connect to Printer
Windows cannot connect to printer.
Details: Operation failed with error 0x0000007e.
=================
Note: 0x0000007e/ERROR_MOD_NOT_FOUND: The specified module could not be found.


Therefore, the printer driver cannot be installed and you cannot share the printer with the client computer.

↑ Back to the top


Cause

This issue occurs because, after the printer is installed, Windows 7 or Windows Server 2008 R2 incorrectly looks for the Mscms.dll file in a subfolder different than the windows\system32 subfolder.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 or Windows Server 2008 R2 on the computer.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.20707768,00005-May-201007:05x86
Winprint.dll6.1.7600.1638529,69614-Jul-200901:16x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.20707954,36805-May-201007:21x64
Winprint.dll6.1.7600.1638539,42414-Jul-200901:41x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7600.207072,051,58405-May-201005:49IA-64
Winprint.dll6.1.7600.1638590,62414-Jul-200901:50IA-64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_1ed35da7eb57b41939c4d551f901f90a_31bf3856ad364e35_6.1.7600.20707_none_37e805b1b11de3bc.manifest
File version
File size718
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20707_none_30d3d6900cdc98b1.manifest
File version
File size4,844
Date (UTC)05-May-2010
Time (UTC)11:43
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_1ed35da7eb57b41939c4d551f901f90a_31bf3856ad364e35_6.1.7600.20707_none_9406a135697b54f2.manifest
File version
File size720
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameAmd64_a82d49de4a58d02f63929c78e95ed2ee_31bf3856ad364e35_6.1.7600.20707_none_a3c47bd6b960ba03.manifest
File version
File size722
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameAmd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20707_none_8cf27213c53a09e7.manifest
File version
File size4,845
Date (UTC)05-May-2010
Time (UTC)12:01
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_73672fa56aea7a3054afaab3375ebd81_31bf3856ad364e35_6.1.7600.20707_none_d40885115ecd51cc.manifest
File version
File size720
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable
File nameIa64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7600.20707_none_30d57a860cdaa1ad.manifest
File version
File size4,844
Date (UTC)05-May-2010
Time (UTC)10:46
PlatformNot Applicable

↑ Back to the top


Keywords: kb, kbprb, kbsurveynew, kbexpertiseadvanced, kbhotfixserver, kbautohotfix, kbqfe, kbfix

↑ Back to the top

Article Info
Article ID : 982728
Revision : 1
Created on : 1/7/2017
Published on : 5/1/2013
Exists online : False
Views : 392