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You cannot update some driver files on a computer that is running a Windows 7 or Windows Server 2008 R2 operating system that was deployed by using a generalized system image


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows 7 or Windows Server 2008 R2.
  • You use one of the following methods to prepare a generalized image:
    • At the command prompt, you change to the "%WINDIR%\system32\sysprep" directory and then type the following command:

      sysprep /generalize

      Note If you specify the /unattend parameter together with an answer file when you run this command, you do not set Microsoft-Windows-PnpSysPrep\PersistAllDeviceInstalls to TRUE in the answer file. By default, the value of Microsoft-Windows-PnpSysPrep\PersistAllDeviceInstalls is FALSE.
    • Click Computer, locate the "%WINDIR%\system32\sysprep" directory under drive C.�Then double-click Sysprep.exe and�select the�Generalize�check box.
  • You create the system image by using the ImageX tool.
  • You deploy the system image to a destination computer.
In this scenario, you cannot update some driver files on the destination computer.

For example, you build a Windows 7 generalized image and then deploy the image to another computer. When you try to install the updated Sdbus.sys driver that is described in the following Microsoft Knowledge Base article, the installation fails and you do not receive an error message.
976092� An update is available to fix a data corruption issue for Secure Digital (SD) cards in Windows 7

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Cause

This issue occurs because of an error in Sppnp.dll. This behavior causes some driver files in the system to have incorrect access control lists (ACL). Specifically, the owners of some driver files are designated as a Trusted Installer. Therefore, you cannot update some driver files.

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Resolution

To address this issue, apply the hotfix before you use the sysprep tool to prepare a generalized system image.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sppnp.dll6.1.7600.20713115,20014-May-201002:24x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sppnp.dll6.1.7600.20713102,40014-May-201001:56x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Sppnp.dll6.1.7600.20713181,76014-May-201001:20IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the System Preparation tool, visit the following Microsoft website: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameUpdate.mum
File versionNot applicable
File size1,459
Date (UTC)14-May-2010
Time (UTC)17:17
PlatformNot applicable
File nameX86_1fa190ed29682bed1ad5e8e5486950dd_31bf3856ad364e35_6.1.7600.20713_none_2c6515c32e24cb8b.manifest
File versionNot applicable
File size698
Date (UTC)14-May-2010
Time (UTC)17:17
PlatformNot applicable
File nameX86_microsoft-windows-pnpsysprep_31bf3856ad364e35_6.1.7600.20713_none_426722fd314c9593.manifest
File versionNot applicable
File size4,762
Date (UTC)14-May-2010
Time (UTC)09:31
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_93476aca280ccf86023eb208c05d8dd9_31bf3856ad364e35_6.1.7600.20713_none_f57b636290e03b49.manifest
File versionNot applicable
File size702
Date (UTC)14-May-2010
Time (UTC)17:17
PlatformNot applicable
File nameAmd64_microsoft-windows-pnpsysprep_31bf3856ad364e35_6.1.7600.20713_none_9e85be80e9aa06c9.manifest
File versionNot applicable
File size4,769
Date (UTC)14-May-2010
Time (UTC)04:23
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,689
Date (UTC)14-May-2010
Time (UTC)17:17
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_ad88c64fb616fc5e16e1c4e5e8c70a7a_31bf3856ad364e35_6.1.7600.20713_none_c1076be37d042a74.manifest
File versionNot applicable
File size700
Date (UTC)14-May-2010
Time (UTC)17:17
PlatformNot applicable
File nameIa64_microsoft-windows-pnpsysprep_31bf3856ad364e35_6.1.7600.20713_none_4268c6f3314a9e8f.manifest
File versionNot applicable
File size4,765
Date (UTC)14-May-2010
Time (UTC)03:51
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,684
Date (UTC)14-May-2010
Time (UTC)17:17
PlatformNot applicable

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Keywords: kbexpertiseadvanced, kbexpertiseinter, kbqfe, kbHotfixServer, kbfix, kbsurveynew, kbautohotfix, KB982646

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Article Info
Article ID : 982646
Revision : 2
Created on : 6/10/2010
Published on : 6/10/2010
Exists online : False
Views : 487