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MIME or S/MIME messages that are signed or encrypted are not parsed correctly when you use the MIME/SMIME Decoder in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a receive location to receive and to process MIME and S/MIME messages in Microsoft BizTalk Server 2006 R2.
  • You use a pipeline that includes the MIME/SMIME Decoder pipeline component in the receive location.
  • You receive a signed or encrypted MIME or S/MIME message in BizTalk Server 2006 R2.
In this scenario, you may experience one of the following problems.

Problem 1

The message is suspended. Additionally, an error message that resembles the following is logged in the Application log:
Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5753
Description: A message received by adapter "<Adapter Name>" on receive location "<Receive Location Name>" with URI "<URI>" is suspended.
Error details: There was a failure executing the receive pipeline: "<Pipeline name>, <Pipeline assembly name>, Version=1.0.0.0, Culture=neutral, PublicKeyToken=<Token>" Source: "MIME/SMIME decoder"
Receive Port: "<Receive Port Name>" URI: "<URI>" Reason: There was an authentication failure. "Failed to decode the S/MIME message. The S/MIME message may not be valid."�

Problem 2

The message is received by BizTalk Server 2006 R2. However, the MIME boundary is included as part of the message. Therefore, the message is incorrect.

Note�These problems also occur when you use the POP3 adapter in the receive location.

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Cause

This problem occurs because of an error in the Exsmime.dll�file that is included in BizTalk Server 2006 R2. Because of this error, the MIME/SMIME Decoder pipeline component does not correctly parse MIME and S/MIME messages under certain conditions.

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Resolution

The hotfix that resolves this problem is included in Cumulative Update Package 2 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2211420� Cumulative update package 2 for BizTalk Server 2006 R2 Service Pack 1
For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
974563� List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907� Information on BizTalk Server hotfixes

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB982634, kbfix, kbexpertiseadvanced, kbsurveynew, kbautohotfix, kbqfe, kbbtspipeline, kbbiztalk2006r2presp2fix

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Article Info
Article ID : 982634
Revision : 3
Created on : 7/28/2010
Published on : 7/28/2010
Exists online : False
Views : 495