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An MSCSProfile cookie is not assigned to client computers that visit a Commerce Server 2007 site


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a server that is running Microsoft Commerce Server 2007.
  • You create a Commerce Server site that is based on the Commerce Server 2007 Starter Site. Or you use the CommerceDataWarehouseAuthenticationModule class in a site.
  • An anonymous user visits the Commerce Server site from a client computer.
In this scenario, no MSCSProfile cookie is assigned to the client computer. Then, some Commerce Server modules that use an MSCSProfile cookie may not function correctly.

Note Commerce Server uses MSCSProfile tickets to identify and track anonymous users who visit your site. MSCSProfile tickets are usually stored in persistent cookies for users who allow persistent cookies. When users do not allow persistent cookies, the MSCSProfile ticket is encoded in the URL.

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Cause

This issue occurs because some old MSCSProfile cookies exist on the client computer. For example, these cookies are assigned when a user visits a site that is previously running Commerce Server 2002. After you move your site to Commerce Server 2007, the Commerce Server CS Authentication encryption key that Commerce Server 2007 uses cannot decrypt the old cookies from Commerce Server 2002.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Commerce Server 2007 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) after you apply this hotfix. To restart IIS, at a command prompt, type the following command, and then press ENTER:
IISRESET /RESTART
Note This option stops and then restarts all IIS services that are running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.commerceserver.runtime.dll6.0.4109.44845,69607-May-201015:00x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the CommerceDataWarehouseAuthenticationModule class, visit the following Microsoft Developer Network (MSDN) Web site:The latest version of the Commerce Server starter site is Commerce Server 2007 Starter Site R2. To download Commerce Server 2007 Starter Site R2, visit the following Microsoft Web site:

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Keywords: KB982554, kbqfe, kbsurveynew, kbexpertiseadvanced, kbautohotfix

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Article Info
Article ID : 982554
Revision : 4
Created on : 10/6/2011
Published on : 10/6/2011
Exists online : False
Views : 385