Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The monitoring of SNMP devices may stop intermittently in System Center Operations Manager or in System Center Essentials


View products that this article applies to.

Symptoms

When you monitor some Simple Network Management Protocol (SNMP) devices by using System Center Operations Manager�or System Center Essentials,�the monitoring may stop intermittently. This issue affects the SNMP performance collection rules or the SNMP event monitors.

After you restart the OpsMgr Health service or the System Center Management service on the proxy agent, the monitoring of the SNMP devices continues as usual for a while. However, this issue may again occur sometime later.�

Additionally, the following event is logged in the Operations Manager log when this issue occurs:

Source: HealthService
Date: date
Event ID: 4000
Task Category: Health Service
Level: Error
Keywords: Classic
User: N/A
Computer: computer name
Description:
A monitoring host is unresponsive or has crashed. The status code for the host failure was 2164195371.


Note This issue occurs on a computer that is running any version of System Center Operations Manager or of System Center Essentials.

↑ Back to the top


Cause

The issue�occurs because of a race condition in the SNMP service.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you�must be running�Windows Server 2003 Service Pack 2 (SP2).

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wsnmp32.dll5.2.3790.471044,03214-May-201015:06x86
Updspapi.dll6.3.4.1379,18401-Mar-200706:10x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wsnmp32.dll5.2.3790.471069,12014-May-201013:00x64SP2SP2QFE
Wwsnmp32.dll5.2.3790.471044,03214-May-201013:00x86SP2SP2QFE\WOW
Updspapi.dll6.3.4.1462,12814-May-201013:05x64NoneNot Applicable
For all supported IA-64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wsnmp32.dll5.2.3790.4710131,58414-May-201013:00IA-64SP2SP2QFE
Wwsnmp32.dll5.2.3790.471044,03214-May-201013:00x86SP2SP2QFE\WOW
Updspapi.dll6.3.4.1655,15214-May-201013:05IA-64NoneNot Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
961363� Operations Manager 2007 Service Pack 1 may stop monitoring SNMP devices

↑ Back to the top


Keywords: kbHotfixServer, kbautohotfix, kbsurveynew, kbexpertiseadvanced, kbqfe, kbfix, KB982501

↑ Back to the top

Article Info
Article ID : 982501
Revision : 2
Created on : 6/10/2010
Published on : 6/10/2010
Exists online : False
Views : 801