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A long delay occurs when you click "Refresh" to view the latest membership in a dynamic collection on a System Center Configuration Manager 2007 SP2 site server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create lots of dynamic collections on a System Center Configuration Manager Service Pack 2 (SP2) site server by using the query-based rules. For example, you create several thousand of these collections.
  • In the Configuration Manager console, you click Refresh to view the latest membership in a dynamic collection.
In this scenario, the Configuration Manager console requires a long time to display the latest membership. This delay lasts from several minutes to several hours.

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Cause

This issue occurs because Collection Evaluator maintains a first-in, first-out (FIFO) queue to handle the collection evaluation requests.

When you click Refresh to view the latest membership of a collection, this request is put at the end of a FIFO queue. If the number of previous requests is very large, Collection Evaluator requires a long time to complete the previous requests. Therefore, a long delay occurs before you view the updated results in the Configuration Manager console.

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Resolution

After you install this hotfix, Collection Evaluator prioritizes the queue to give any request from the user interface (UI) a high priority. Therefore, a UI request is handled in a timely manner even if there are many back-end requests in the queue.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have System Center Configuration Manager 2007 Service Pack 2 (SP2) installed.

Installation instructions

Note The following hotfix package can be installed on a System Center Configuration Manager 2007 SP2 site server that is running an x86-based version of an operating system or an x64-based version of an operating system:
SCCM2007-SP2-KB982400-ENU.msi

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
System Center Configuration Manager 2007 file information notes
File nameFile versionFile sizeDateTimePlatform
Colleval.dll4.0.6487.2135102,24801-Feb-201011:50x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseinter, kbautohotfix, kbhotfixserver, kbqfe, kbfix, kbsurveynew, kb

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Article Info
Article ID : 982400
Revision : 3
Created on : 9/20/2018
Published on : 9/20/2018
Exists online : False
Views : 258