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The startup time increases or hangs at the logon “Welcome” screen if you frequently backup Hyper-V virtual machines on a Windows Server 2008 R2 system


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2008 R2 and that has the Hyper-V role installed, the startup time of the computer keeps increasing. After a while, the computer stops responding when the computer is in the startup process.

Note If the computer runs some virtual machines, this issue usually occurs when you frequently back up all the disks on the computer.

Additionally, many of the following PlugPlayManager events that have Event ID 12 are logged in the System log:


Notes
  • The size of the %SystemRoot%\system32\config\system system registry hive increases after every backup operation..
  • If you view the registry hive by using Registry Editor, the following registry entries are logged repeatedly. For example, the following registry entries are logged repeatedly 10000 times or more.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\SCSI\Disk&Ven_Msft&Prod_Virtual_Disk

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\STORAGE\Volume\{f1030a29-1024-11df-b7a9-001b214f4bef}#0000000006500000

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses\{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}\##?#STORAGE#VOLUME#{E717314D-23B5-11DF-AA86-001B214F4BEF}#0000000000100000#{53f5630d-b6bf-11d0-94f2-00a0c91efb8b}"DeviceInstance"="STORAGE\\Volume\\{e717314d-23b5-11df-aa86-001b214f4bef}#0000000000100000"
  • This issue also occurs in Windows Server 2008. However, no hotfix is available for Windows Server 2008. To work around this issue, see the "Workaround" section.

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Cause

This issue occurs because there are a large amount of orphaned registry keys.

The Volume Shadow Copy Service (VSS) snapshots create many registry keys. However, they are not deleted after the VSS snapshot operations are completed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2. Additionally, you must have the Hyper-V role installed.

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Vhdmp.sys6.1.7600.20714217,98418-May-201004:14x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Vhdmp.sys6.1.7600.20714482,68818-May-201002:04IA-64



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Workaround

Important
Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

To work around this issue in Windows Server 2008 R2 or Windows Server 2008, clean up all orphaned registry key entries. To do this, follow these steps: 
  1. Download the DevNodeClean tool.
  2. Perform one of the following operations:
    • Run the DevNodeClean tool as administrator.
    • At a command prompt, locate to the folder path of the DevNodeClean.exe file, type the following command, and then press ENTER:
      devnodeclean /r

      Note
      We recommend that you schedule the devnodeclean /r command to run one time every week.
If the DevNodeClean tool does not work, you can delete the registry keys manually or contact Microsoft Support for help.

For more information about the devnodeclean command, click the following article number to view the article in the Microsoft Knowledge Base:
934234 How to remove registry information about devices that will never be used again on a computer that is running Windows Server 2003

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_vhdmp.inf_31bf3856ad364e35_6.1.7600.20714_none_0359a1b5fc340e52.manifest
File versionNot applicable
File size2,079
Date (UTC)18-May-2010
Time (UTC)08:58
PlatformNot applicable
File namePackage_1_for_kb982210~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,840
Date (UTC)18-May-2010
Time (UTC)11:49
PlatformNot applicable
File namePackage_2_for_kb982210~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,840
Date (UTC)18-May-2010
Time (UTC)11:49
PlatformNot applicable
File namePackage_3_for_kb982210~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size1,816
Date (UTC)18-May-2010
Time (UTC)11:49
PlatformNot applicable
File namePackage_for_kb982210_rtm~31bf3856ad364e35~amd64~~6.1.1.0.mum
File versionNot applicable
File size2,180
Date (UTC)18-May-2010
Time (UTC)11:49
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_vhdmp.inf_31bf3856ad364e35_6.1.7600.20714_none_a73caa2843d4a618.manifest
File versionNot applicable
File size2,077
Date (UTC)18-May-2010
Time (UTC)04:25
PlatformNot applicable
File namePackage_1_for_kb982210~31bf3856ad364e35~ia64~~6.1.1.0.mum
File versionNot applicable
File size1,835
Date (UTC)18-May-2010
Time (UTC)11:49
PlatformNot applicable
File namePackage_for_kb982210_rtm~31bf3856ad364e35~ia64~~6.1.1.0.mum
File versionNot applicable
File size1,444
Date (UTC)18-May-2010
Time (UTC)11:49
PlatformNot applicable

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Keywords: kb, kbhyperv, kbqfe, kbsurveynew, kbexpertiseadvanced, kbhotfixserver, kbautohotfix, kbfix

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Article Info
Article ID : 982210
Revision : 1
Created on : 3/21/2017
Published on : 2/28/2015
Exists online : False
Views : 270